Vosonic portable drive failed

  grumpy-git 16:06 04 Jan 08
Locked

I have an Xs drive which I use for copying the images from my memory cards. It recently stopped working.

It is out of guarantee & Vosonic do not reply to e-mails. Does anybody have any knowledge of these drives?

When I switch it on, it powers off within a few seconds. Tried it on battery power & plugged in to mains, but result is the same. I have had a look inside & there do not appear to be any lose connections.

Any suggestions please?

g-g

  €dstowe 16:13 04 Jan 08

What about contacting the company you bought it from?

  grumpy-git 16:30 04 Jan 08

Edstowe,

Not sure who I bought it from now, it was over 2 years ago. Had it been within the first year & under guarantee then they may have replaced it or suggested what to do. Will have to try & find the receipt.

Pity I haven't a spare 2.5" drive, I could try exchanging it for the one in the Xs drive.

g-g

  grumpy-git 18:50 31 Jan 08

Haven't solved the problem with the Xs drive, but bought a 2.5" caddy for 11.74 from Morgan Computers, fitted the 40gb hard drive - and it works.

Now I have a 40gb external hard drive.

g-g

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…