Vista thinks Wireless receiver is on when it's off

  Nick052 18:53 13 Aug 07
Locked

Hi,

I have a brand new laptop running Windows Vista Home Premium.

The laptop has Wi-fi capabilities, and there is a button to turn this off and on, with a corresponding LED to notify you. Also, when you press the button, you get a Windows pop-up box that says "Wireless LAN Wi-fi" with a check-box next to it. Pressing the button toggles the check-box off and on.

The issue I am having is that even if my wireless capability is supposed to be off (with the LED not lit and the box unchecked), Windows Vista can still connect to my home wireless network and I am still able to go on the internet!

Anyone any ideas why this is happening?

  Bronica 19:51 13 Aug 07

Once you have conected to your network and Internet is the wireless LED still not on or does Vista reconnect the Wifi on demand?

Does the Laptop have a wireless network manager or is Vista in control?

  Nick052 20:04 13 Aug 07

Thanks for the reply.

Yes, even when the LED is still not on, Windows Vista still connects. So it's not as if Vista is turning it back on I don't think. Its almost as if the button has no effect!

And im pretty sure Vista is in control of things.

  Bronica 20:46 13 Aug 07

Open control panel then Network and sharing center.

There should be an entry for your network about half way down. There is a link to check status open that then try operating the button that turns off wifi and see if the status changes yo disconected.

  Nick052 20:53 13 Aug 07

Just tried it - the status did not change when I turned it off. Still shows as connected.

  Bronica 21:00 13 Aug 07

If you now check properties is the network device listed the wireless conector in the laptop? There is not more than one wireless device listed is there?

  Nick052 21:14 13 Aug 07

Im pretty sure there is only one listed and it's called "Atheros AR5007UG Wireless Network Adapter". Im sure this is the one in the laptop.

  Bronica 21:30 13 Aug 07

There are alot of posts around this adapter not working with Vista but you seem to have the opposite problem.

What make of laptop is it? I think I might do a little investigating and get back to you.

  Nick052 21:36 13 Aug 07

It's a "Medion" laptop with Intel Core Duo 1.86Ghz processor and 2Gb RAM.

I guess this is not really a big deal, its just something that will probably annoy me!

  Bronica 18:21 17 Aug 07

I have had a look at these laptops and your wirless card seems very popular in them. There are a number of reported issues and fixes for drivers for Vista but nothing like your problem most seem to be around getting the card to work or configured. I would guess at a driver issue but unless this is really driving you mad I would leave well alone while the wifi is working.

  Nick052 09:56 01 Sep 07

Thanks for the reply. I will leave well alone! I can always disable the device in Network Connections if I need to.

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced