vista-epson d92 print problem

  bth 10:31 01 Nov 07
Locked

my epson d92 works perfectley well when im logged on to my account as an administrator, as soon as we change to another account(son,guest,wife)the printer plays up.my account shows the printer icon in the bottom right corner.
when account changed no icon appears, press print and it will print one copy then a box flashes up showing the ink amounts and saying printer ready, this will not go away when you try to close it, just keeps flashing up preventing any other action.
this then freezes the computer.
i am a novice so it may be a simple thing.
i have tried removing and reloading the printer disc but still no joy,
please help!
i could let the kids use the computer under my account but as an administrator i dont want them messing with the settings as its all new to me

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

VFX Oscar nominees 2017: Discover how the visual effects were created

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…