Vista - device manager blank, and can't install scanner

  onthelimit1 18:25 PM 12 Jan 13
Locked

Next door called me with a problem last week as her scanner had stopped working - I couldn't get it to work. She bought a new Epson and tried to install. All went well until plugged in and Windows couldn't install the software. Thought I'd check device manager. Totally blank. Tried suggestions on Google - start P&P in services - already running. Edit a registry key - already as the suggestion. Seems there was nothing wrong with the old printer, just a glitch in Windows somewhere.

I feel a re-install may be the answer, but thought I'd check if anyone has come across this and has an alternative solution.

  onthelimit1 18:27 PM 12 Jan 13

P.S. Have tried scannow and a repair install

  northumbria61 18:45 PM 12 Jan 13

Don't know how you are doing it but the software is normally installed first before plugging in the scanner.

  northumbria61 18:49 PM 12 Jan 13

If the Device Manager is till showing empty list try the following -

  1. Click Start, click Run, type services.msc, and then click OK.
  2. Double-click Plug and Play. (If you receive a Configuration Manager message, click OK.)
  3. In the Startup Type list, click Automatic, and then click OK.
  4. Close Services.
  5. Restart the computer.
  Fruit Bat /\0/\ 19:10 PM 12 Jan 13

Looks as if you have lost permissions to view devmngnt

Back up everything first before you:

Reset Vista default permissions, then grant permissions to your admin user account (the one you normally use OK). Try the following steps.

  1. Download the subinacl.msi file to your desktop

  2. On the Desktop and double click the downloaded file.

  3. Select the C:\Windows\System32 folder as the Destination Folder during the installation. Later this tool is used to reset the permission settings on the current machine.

    Note: If UAC (User Account Control) window is prompted for permission to continue, please click "Continue"

  4. Click "Start". In the Start Search bar, type: notepad and press Enter.

  5. Copy the following commands and then paste them into the opened Notepad window:

    @echo off

    subinacl /subkeyreg HKEYLOCALMACHINE /grant=administrators=f

    subinacl /subkeyreg HKEYCURRENTUSER /grant=administrators=f

    subinacl /subkeyreg HKEYCLASSESROOT /grant=administrators=f

    subinacl /subdirectories %SystemDrive% /grant=administrators=f

    subinacl /subdirectories %windir%*.* /grant=administrators=f

    subinacl /subkeyreg HKEYLOCALMACHINE /grant=system=f

    subinacl /subkeyreg HKEYCURRENTUSER /grant=system=f

    subinacl /subkeyreg HKEYCLASSESROOT /grant=system=f

    subinacl /subdirectories %SystemDrive% /grant=system=f

    subinacl /subdirectories %windir%*.* /grant=system=f

    @Echo =========================

    @Echo Finished.

    @Echo =========================

    @pause

  6. After the above commands are finished, close the Notepad window. Choose Save when you are prompted to save the file. Type "reset.bat" as the file name and choose Desktop from the left panel as the save location.

  7. Refer to the Desktop and right click the reset.bat file, then choose "Run as administrator."

  8. You should see a DOS-like window processing.

NOTE: It may take several minutes. When it is finished, you will be prompted with the message: "Finished, press any key to continue".

Now to reset your user permissions:- log in as your normal user

Go to start, all programs, accessories and right click on command prompt select "run as administrator" command prompt will open C:\Windows\system32> type

takeown /f C:\windows

press enter

SUCCESS: The file (or folder): "C:\windows" now owned by user your user name.

C:\Windows\system32> type

icacls c:\windows /grant your user name:f

processed file: c:\windows Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32> type

takeown /f C:\

SUCCESS: The file (or folder): "C:\" now owned by user your user name"..

C:\Windows\system32> type

icacls C:\ /grant your user name.:f

processed file: C:\ Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>

Type Exit press enter RESTART computer

  onthelimit1 19:21 PM 12 Jan 13

northumbria - as I mentioned, P&P already running. FB - thanks - I'll try that when I have their computer here when they go to Mexico to watch whales (aright for some), so will be sometime before I report back.

Advertisement

This thread is now locked and can not be replied to.

Sony Xperia Z5 vs Xperia Z5 Premium vs Xperia Z5 Compact: What's the difference between Sony's new ?…

1995-2015: How technology has changed the world in 20 years

Get $800 of free online Nuke and VRay rendering from Google Zync

iPhone 6S preview: What to expect from Apple's next iPhone