hugoboss38 22:17 PM 05 Apr 13

help help needed hi there ive got a emachine laptop D620-5777 that im trying to connect to my wifi It's running vista im trying to connect to my network but for some reason its not allowing me to connect to anything it finds the network's but when i put my password key says connected but when i look at the network and sharing center saying my name of my pc then unidentified network then between that and the internet got a red cross in the middle of them but this happens on anyone network so plz can you help me solve this issue ive even tried connecting my earthnet cable to the bt infinity router but still wont allow it to connect very frustrating person

  difarn 22:34 PM 05 Apr 13

Have you tried switching your router off and on again and then connecting by ethernet?

Are your network drivers up to date - check in device manager.

You could try resetting the Internet Protocol by using the Fix it in this article.

If this doesn't work delete your network from available networks then connect your pc by ethernet cable to the router and go through the process again.

There may be a chance that your antivirus is blocking access. You could try temporarily disabling this while you try to connect.


This thread is now locked and can not be replied to.

Best Black Friday deals 2015 live blog: Best UK Black Friday deals & best UK Black Friday tech…

1995-2015: How technology has changed the world in 20 years

ZAK releases more videos showing what happens if you ask other professions to work for free

20 Mac Power User Tricks... That You Didn't Know