Very strange situation with PC Advisor login....

  hawthorn59 20:10 PM 10 Sep 12

Hi Folks

This is weird. I tried last week, and again today, to log in to the PC Advisor website but to no avail. Eventually I clicked "forgot password" and entered my email address, to be told it wasnt linked to any account etc.

So not being able to find any other way to contact help on the site, I reluctantly created, as I thought, a new account, and registered. I used the same email address, and password, but a different username.

Lo and behold, when I logged in, I was back to my old account....???? Great that Im not losing my old posts but surely very very strange....? How could this happen? What about security etc?

Just wondering!


  Woolwell 20:21 PM 10 Sep 12

The PCA site has been experiencing a few problems recently. You are not alone.

  hawthorn59 20:24 PM 10 Sep 12

Ah. OK!

  Fruit Bat /\0/\ 20:39 PM 10 Sep 12

because you used same email and password instead of creating new account you effectively modified your account profile.

Click on my profile at op of page and you can probably change back to your old username.

  hawthorn59 21:13 PM 10 Sep 12

Actually its quite ok, never really used the username much anyway!




This thread is now locked and can not be replied to.

Microsoft Lumia 950 vs Lumia 950 XL: What's the difference between Lumia 950 & 950 XL?

1995-2015: How technology has changed the world in 20 years

How Medium's new logo was designed

iPad Pro vs iPad Air 2 comparison: Which of Apple's flagship iPads is best for you?