USRobotics router problem

  item 12:37 29 Nov 04

I have a US robotics4 port router and a D-Link ADSL modem to which 2 pcs running Xp have been connected. This arrangement has worked fine for 3 months. Yesterday I tried to add a 3rd Pc and since then I have major problems. I added the 3rd Pc to no 3 LAN port and could not get a connection. I have removed this cable and gone back to the original 2 PC on LAn sockets 1 & 2 but cannot get a connection to the internet or the LAN.
I can connect each PC direct through the modem and the host PC to the internet when connected to the router but neither PC if both connected to the router.
The LAN lights on LAN 3 are on at all times , even after switching the router off and on, and after using the reset button. I suspect the router. Any ideas would be appreciated.

This thread is now locked and can not be replied to.

Surface Studio vs iMac 5K comparison review: Apple and Microsoft all-in-one PCs battle it out

1995-2015: How technology has changed the world in 20 years

Social media image sizes, specs and aspect ratios: the ultimate guide

New MacBook Pro release date, price and specs | New MacBook Pro 2016 announced: Now with Touch Bar…