usb2.0 hub only 1 speed

  muffled mouse 23:14 09 Jul 03
Locked

I have a usb 2.0 pci card installed. When my external hard drive and cd-rewriter are plugged into the card they function as high speed usb 2.0 devices. Now here is the question, when I attatch the Belkin usb 2.0 hub to the card everything I plug in to the hub is only running 1 speed. Hard drive is really slow, and max speed from cd-rewriter is 4X. The hub will run at usb 2.0 as I had it checked on another machine, Windows 2000, I am running Windows 98 se. Anybody know anything ?

  DieSse 23:50 09 Jul 03

Sounds like a problem with the PCI card - What chipset does it use - Via are generally reckoned to be the most problematic.

  BillEmm 15:07 10 Jul 03

You need to check with the manufacturer of your USB 2.0 drive to see if it can run off a hub and if so which hub. Many mass storage devices are not happy unless they are connected directly off a USB 2.0 port or a particular hub.

If there is too much attenuation between the device and the PC (the additional hub device and extra cable) the device may switch modes which will then signal to the OS that everything on that port is now USB 1.1.

Just a thought.

Bill

This thread is now locked and can not be replied to.

Amazon Fire HD 8 review: A brilliant combination of function and value – with one massive caveat

1995-2015: How technology has changed the world in 20 years

How to create an introvert-friendly workplace

iPhone 7 review: Enhanced cameras, a refreshed design and water resistance make the iPhone 7 an…