USB2 behaves like USB1

  fudge 19:42 06 Jun 06

I've been using a PCI to USB2 device under Windows ME and it worked fine. I've recently upgraded to Win XP (SP2) and now its performance is like USB1.

I've got the latest drivers and the device manager clearly shows it as an Enhanced Host Controller, so it recognises it as USB2.

I use a USB2 flash memory for backup so it's been easy to see the speed has dropped. I'm not running any other USB devices from this card.

Why would the performance drop with the upgrade to XP, or is there something else that could have changed?

  mgmcc 20:43 06 Jun 06

Try updating the USB drivers in Device Manager. There can be a problem with SP2 where the USB drivers aren't installed correctly, although this tended to happen when updating to SP2 from either basic XP or from SP1

  Fruit Bat /\0/\ 20:49 06 Jun 06

Uninstall everything under the heading USB in device manager.

Reboot let XP find new hardware and reinstall the ports for you.

This will "refresh all the ports.

See if this makes any difference, it should do.

  fudge 20:58 06 Jun 06

I've updated the drivers which made no difference. I've already tried uninstalling this particular USB device but I'll try all of them as you suggest Fruit Bat. I'll see what happens.

  Fruit Bat /\0/\ 21:04 06 Jun 06

Not just the device but all the root hubs have to go.

  fudge 21:13 06 Jun 06

I've now removed everything that was under the heading USB, including root hubs. Windows has now found the hardware and re-installed all the drivers and guess what - absolutely no difference. It's still chugging along like an old cart horse!

The USB ports at the rear, which are on a different card, work fine. In fact by the way they now perform I think they must have been running slow on the old system because they seem much faster now.

Which makes me wonder whether the motherboard can't support this number of USB2 ports. What do you think?

  Fruit Bat /\0/\ 21:23 06 Jun 06

Any idea what your mobo USB chipset is? VIA / Intel ?

  woodchip 21:27 06 Jun 06

What chipset does your Motherboard Have?????

  fudge 22:00 06 Jun 06

Via VT8366 Northbridge and Via VT8233 Southbridge

  Fruit Bat /\0/\ 22:12 06 Jun 06
  woodchip 22:20 06 Jun 06

Have a look hear as I think you need to download it and install click here

This thread is now locked and can not be replied to.

iPhone 7 Plus review: better cameras and waterproofing make this the best iPhone yet

1995-2015: How technology has changed the world in 20 years

Apple to launch new Macs and MacBook Pros at an event on October 27

iPhone vs Android | iOS vs Android: 5 reasons why Apple's iPhones beat Google Android smartphones ()…