USB Stopped working

  effingpot 17:16 25 Nov 06
Locked

Hi, I have an external USB HDD from Freecom which has worked fine on my Mesh desktop using the two front USB ports. One provides power. Recently when plugged in, it (and other USB devices) generate a device not recognised error. Same on memory keys. I tried using the USB ports on the reverse of the machine and it appeared to work but after about 30 secs of recogniseing the device, the same error. There is no device driver avail for XP as it's supposed to be autosensing from the OS. In the device manager there is an 'unknown' device listed but it seems like the USB hardware or subsystem is fauly. All cables seem tight and in place.

Any ideas what to do?
Thanks
Mike

  Technotiger 17:21 25 Nov 06

Hi, for a start, I would unplug as many of your usb devices as possible and then try a System Restore. After restore re-connect devices and see if that helps. Sorry, I am just guessing, but worth a try I think. Gotta start somewhere.

Cheers

  skidzy 17:22 25 Nov 06

Mike have you tried to uninstall evrything under USB headings in Device manager and reboot.XP will reload the generic drivers.

  effingpot 17:26 25 Nov 06

Thanks for the quick replies - I'll try both. Daft question - how do I do a restore please?

  Technotiger 17:28 25 Nov 06

Restore - Start>All Programs>Accessories>SystemTools>System Restore

  Technotiger 17:28 25 Nov 06

PS - there is no such thing as a 'daft question' ...

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Here's what should be coming to Adobe Project Felix in 2017

Apple AirPods review: Apple's beautiful new Bluetooth headphones bring true intelligence to…