USB and SD card not showing in my computer

  ukbahaiguy 19:48 03 Jan 15
Locked

hi all,

my USB and SD cards are not showing up in my computer. All seems to be ok when plugging my usb phone connector but usb sticks and sd cards are not showing.

Operating System System Model Windows 7 Home Premium (x64) Service Pack 1 (build 7601) Install Language: English (United States) System Locale: English (United Kingdom) Installed: 11/07/2011 18:15:47 Boot Mode: BIOS (Secure Boot not supported) Packard Bell imedia S1800 System Serial Number: PTU59E2403111057BF2703 Enclosure Type: Desktop Processor a Main Circuit Board b 3.20 gigahertz Intel Pentium Dual-Core 64 kilobyte primary memory cache 2048 kilobyte secondary memory cache 64-bit ready Multi-core (2 total) Not hyper-threaded Board: Packard Bell imedia S1800 Serial Number: U01W104321234 Bus Clock: 200 megahertz BIOS: American Megatrends Inc. P01-A4 06/12/2010 Drives Memory Modules c,d 981.84 Gigabytes Usable Hard Drive Capacity 455.26 Gigabytes Hard Drive Free Space

ATAPI DVD A DH16ABSH ATA Device [Optical drive]

Hitachi HDS721010CLA332 [Hard drive] (1000.20 GB) -- drive 0, s/n JP2960HD1GSJVD, rev JP4OA3EA, SMART Status: Healthy 3038 Megabytes Usable Installed Memory

Slot 'DIMM0' has 1024 MB Slot 'DIMM1' has 2048 MB Local Drive Volumes

c: (NTFS on drive 0) * 490.65 GB 111.79 GB free
d: (NTFS on drive 0) 491.20 GB 343.46 GB free

  rdave13 20:21 03 Jan 15

Go in to device manager. It's a funny bird in itself. Click on the 'Action' tab on the top. If you get 'Help' on the menu then click a blank space to get rid of. Click the 'Action' tab again and this time select 'Scan for hardware changes'. Might be better to reboot after this.

  Fruit Bat /\0/\ 20:46 03 Jan 15

Malfunctioning USB drives / mem cards

a) Press Windows Key + R and type devmgmt.msc in the Run dialog box to open Device Manager.

b) When the Device Manager window opens, you need to find the USB device which is giving trouble. It may be listed under Human Interface Devices as USB Input Device.

If not there, expand Universal Serial Bus controllers. Find the one in the list for your drive, right click over this entry, pick Properties.

c) In the device properties window, change to Details tab. Click the menu for Properties and select Device Instance Path. Note down the corresponding Value it is a combination of three IDs - namely Vendor ID (VID), Product ID (PID) and Instance ID.

d) Press Windows Key + R combination, type regedit in Run dialog box and press Enter Registry Editor opens.

e) Navigate here:

HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Enum\USB(Device Instance Path)\Device Parameters

Substitute the Device Instance Path part (after USB) with the number obtained from the step c.

f) In the right pane of Device Parameters key look for the DWORD named EnhancedPowerManagementEnabled which must be showing its Value data as 1. Double click on the same to get this:

g) In the above shown box, change the Value data to 0. Click OK. Close the Registry Editor and Device Manager.

h) Reboot the PC and retry.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now