USB problems - please help!

  Limariami 07:08 08 Jul 08
Locked

Hello all

I wonder whether anyone can help me. I'm having serious USB problems and I cannot usemy MP3 player, printer, or external HDD. Symptoms described below.
________________________________________
When i connect a device to the USB connector,
- either 'Found new hardware wizard ' comes up, but never succeeds in finding the driver (before this happened all the time)
- nothing happens (now, probably as a result of stuff I tried, this is more likely)

In both cases, a line with the name of the product (eg Zen Stone Plus) appears under 'Other devices' section (with yellow ! and ?) under Device Manager.
_________________

When I disconnect ALL USB devices, this is the info that appears in Device Manager

Under 'Other devices' section (yellow !)
- Unknown device (with yellow !)
It's position is "on Intel(R) 82801FB LPC Interface Controller - 2640"

Under 'USB Bus Controller (with yellow !) there are 11 lines
- USB Root Hub
- USB Root Hub
- USB Root Hub
Under properties, in 'Connected devices' I see 'USB Mass Storage device'
- USB Root Hub
- USB Root Hub
- Intel 82801 FB/FBM USB Universital Host Controller - 2658
- Intel 82801 FB/FBM USB Universital Host Controller - 2659
- Intel 82801 FB/FBM USB Universital Host Controller - 265A
- Intel 82801 FB/FBM USB Universital Host Controller - 265B
- Intel 82801 FB/FBM USB2 Enhanced Host Controller - 265C
- USB Mass Storage device
Its position is "0 (USB Device)"


It's strange that the PC sees a device that is not connected !
_________________

Windows XP Home Edition SP 2
ACER G91M motherboard
Intel i915G chipset
___________________


I've tried lots of different stuff, includnig:
1)
manual and auto updating of driver (never works)
For the manual search, I browsed only to C/SYSTEM/ becase there seemed to be a lot of drivers here. Could they be storede elsewhere?
2)
updating USB drivers (from Intel)
3)
creating a new registry entry (to stop power from being suspended)
4)
changed some BIOS settings


I looked at your 'USB Troubleshooting guide' and did some stuff. The guide suggests updating the (i) chipset driver and also the (ii) USB2.controller However I cannot find either. Anyone knows how to proceed?

Any feedback or advice welcome. One question in particular - should I be worried about the "phantom" device ?

Regards

  Technotiger 07:11 08 Jul 08

Don't worry about phantom device. Uninstall ALL usb items in devices. Then re-start your computer. New found hardware wizard should then take over, just follow on-screen prompts.

  Limariami 18:49 10 Jul 08

Sorry for delay in replying, Technotiger

It didn't work though.

  Fruit Bat /\0/\ 19:03 10 Jul 08

Use Drive clean up to remove USB device drive info from the registry
click here

then
In device manager Uninstall EVERYTHING under the heading USB, reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  Limariami 19:09 10 Jul 08

Thanks for the suggestions Fruit Bar, however two things:

1)
I am reluctant to download files when I don't know the source. Is there another program that can do the job? Or can I do this manually?

2)
How certain are you that this will work? can you explain your reasoning?

  bluto1 21:55 10 Jul 08

Trust Fruit Bat /\0/\, everyone else does and nobody has ever complained of his efforts to help us. Do as he suggests.

  Technotiger 23:40 10 Jul 08

I second bluto1 and suggest you follow Fruit Bat /\0/\'s directions.

  Ditch999 12:35 11 Jul 08

Remove all hidden USB devices

1. Click Start. Click Run. Type cmd and press OK.

2. Type "set DEVMGR_SHOW_DETAILS=1" (without quotation marks) and press Enter.

3. Type "set DEVMGR_SHOW_NONPRESENT_DEVICES=1" (without quotation marks) and Press Enter.

4. Type "start devmgmt.msc" (without quotation marks) and click press Enter.

5. Click View. Click Show hidden devices.

6. Click "+" to expand Imaging devices, Unknown devices and USB devices.

7. If there any unknown devices (including grayed out devices), right click it and click Uninstall.

8. Reboot the computer.

  Limariami 20:18 11 Jul 08

Fruit Bat - the procedure didn't work.

Ditch999 - couldn't do it because cmd was not recognized...

However thank you for answers and for putting me on the right track. After a lot of trial and error I discovered this page on the Sony website. I tried "Removing USB entries from the Windows Device Manager" and it worked.

click here

Perhaps the key step is removing USB Devices software ?

  Technotiger 20:21 11 Jul 08

Grreat, glad you are sorted ......... and thanks for that useful link - bookmarked.

Cheers.

This thread is now locked and can not be replied to.

Sony Xperia XZ Premium review: Hands-on with the new 4K HDR phone with Motion Eye camera and Snapdr5…

1995-2015: How technology has changed the world in 20 years

Best laptop for design and art 2017: we test Apple, Dell, HP, Lenovo and Microsoft's best models…

CarPlay tips & troubleshooting guide: CarPlay tips & troubleshooting guide: Get the most from…