USB Ports not recognised

  bjantbear 22:01 02 Jul 08
Locked

I have just re-installed Windows XP Home and some of my USB ports are not recognised.

If I put my printer in 1 os the ports at the back it is not seen but id I put in my USB hub which is connected to another port at the back it is recocognised with no problem.

Of the 2 ports on the front there is only 1 that is seen.

What has happened, please?

Should I re-format and re-install my OS?

Regards

  PA28 22:05 02 Jul 08

Have a look in your BIOS (press Del key as the thing boots up to get into it) and check that your USBs are correctly enabled.

  MarvintheAndroid 22:06 02 Jul 08

You probably need service pack 1 to make USB work properly.

Marv

  chub_tor 22:26 02 Jul 08

You don't need to reformat or reinstall. Go to Device Manager, delete all the USB listings at the bottom and let Windows reinstall the drivers.

  woodchip 22:35 02 Jul 08

You need to load Motherboard Drivers from the CD

  MarvintheAndroid 23:00 02 Jul 08

If you haven't installed any service packs yet then do that first, THEN install the USB driver for the motherboard (or delete them and allow Windows to re-install them, same difference).

Marv

  woodchip 23:03 02 Jul 08

As above, but you do not need to download SP1 as SP2 loads the files for it

  MarvintheAndroid 23:05 02 Jul 08

Woodchip is right of course - I only meant that the USB2 update was actually released with SP1. SP2 or dare I say it SP3 will do just as well.

Marv

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

How Nearly Normal created super-fun papercraft for Google

47 iPhone camera tips to help you take better photos