USB pen drive problems

  geordiepaul2001 00:12 08 Nov 10
Locked

Hi all,

I have a 2gb pen drive which was working fine yesterday, however today it shows as 'USB device not recognised'.
I have tried plugging it in when running ubuntu, tried a different laptop, and updating the drivers - all with no success.

Any ideas?
If the USB pen drive is broken is there anyway of recovering the data?

Paul

I posted this elsewhere, for some reason my comp. will not recognises USB 2.0 devices but if I plug them in to a USB 1.1 hub it does!

It is NOT an OLD comp. It did recognise USB 2.0 until a couple of days ago.

  kristain 07:54 08 Nov 10

First try to restore your computer. If dont know how to do restore then follow the steps as below :
1. Select the start button.
2. Select All Programs.
3. Select Accessories
4. Select System Tools.
5. Select System Restore.
6. Select Restore System to an earlier time.
7. Click next.
8. Scroll back to the date you wish to restore to then click next. The computer will start to shutdown, then will restore then shut down and restart itself.

  KremmenUK 08:28 08 Nov 10

I think if the Stick fails to be read on a number of PC's then a 'Restore' on one of them will likely not make any difference.

Sounds to me like a format which will of course lose all data.

Do you get the 'bing bong' when plugging it in to indicate it's being recognised ?

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Framestore’s haunting post-WWII title sequence for new BBC series SS-GB

Best iPhone games 2017 | Best iPad games 2017: 162 fantastic iOS games that you need to play right…