USB non existant on motherboard - updated.

  pj1664 22:11 22 Dec 03
Locked

Hi everyone, I recently puchase a USB mouse and when I connected it to the USB device at the back of my computer the system did not detect the mouse. I realise that the usb device controller is not in my device manager. I have gone into BIOS and enabled USB Mouse but still no avail. I have tried the same mouse on my daughters computer and It works. How do I get the USB Controller to function and appear in my device manager. I have 2 USB ports intergrated in my motherboard and also a PCI card with usb ports but nothing indicated on the BIOS the existance of a usb port. My o/s is 98 and my mother board is Micro-star MS-6390. I have been to their web site to download drivers for my mother board but I have not come accross any drivers for this board or any USB drivers. Is there anywhere else I can this drivers from. Thank You.

  User-312386 22:13 22 Dec 03

have you loaded the drivers for the mouse?

  PA28 22:49 22 Dec 03

You say that you have USB ports on the back of your computer. Are the ports physically connected to the mainboard? Have you enabled USB1 and/or 2 in the BIOS (as well as your mouse)? And, of interest, OS is 98 or 98SE?

  Big Elf 10:51 23 Dec 03

You were asked the same questions in your first post on the subject click here

We need to have answers in order to try and help.

If you haven't had an answer for some time it is acceptable to jump it back to the top by just entering 'bump' or 'refresh' to the thread.

  Rennaissance 11:56 23 Dec 03

drivers should have come on a cd, is the usb ports, onboard or pci? Go to add new hardware and see if anything is detected.

  Belatucadrus 15:32 23 Dec 03

This thread is now locked and can not be replied to.

What is Google Allo? What is Google Duo? Google Allo UK release date and features: Google Allo is…

1995-2015: How technology has changed the world in 20 years

iOS 10 troubleshooting tips: Simple fixes for the most common iOS 10 problems, from network…