USB - No longer works, unknown device

  DTM 13:10 16 Oct 05
Locked

I have just changed cases for better ventilation and now my USB ports do not work properly. I have checked several times that I connected everything to the motherboard correctly but the front ports do not recognise my memory stick and the rear USB ports do not hot swap - only recognises I have an Axim connected if I boot up with it plugged in.

Checking the hardware list I have about 5 entries for unknown device under USB. I installed the lastes nForce drivers for the motherboard but no effect. I have tried uninstalling the unknown devices then letter window find them but still makes them unknown. I am at a loss of what to do.

Thanks in advance for any help.

  DTM 19:57 16 Oct 05

Still no ideas? Looks like possible reinstall of windows?

  QuickHare 20:06 16 Oct 05

Inside the case, the USB ports from the case will either be plugged in with a four-pin wide plug or with four individual plugs for each USB port. Whichever you use, make sure the correct colours are connected up.

If you are sure about this, then it may be that plugging a device into a different USB port causes Windows to reinstall the drivers, which it finds automaticlly and just "links" the drivers to the port. If you can, try the devices in other USB ports. You may find it works, and if this is the case, either swapping the ports around on the motherboard or reinstalling the drivers may help.

However, there is the possibility of Windows becoming corrupt. If the above advice does not work, attempt a reinstall of Windows (which one are you using, by the way?). That may reset where the ports are to Windows.

However, it might also be a hardware fault. Either the ports on the new case are faulty, or the controller on the motherboard/card is shot. The former is repairable by getting a replacement case, as it is faulty under the Sales of Goods Act or Distance Selling Act. If it is the latter, the motherboard will need to be checked or replaced. Have you tried swapping back to the old case to see if it is the motherboard?

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…