USB modem software won't uninstall

  de_de 14:01 17 Nov 07
Locked

Hi,

I have a Thomson Speedtouch 330 USB modem connected to my laptop, running on Vista Home Basic.

It all works OK, but I recentley installed an extra program off the CD called DR Speedtouch, which is a diagnostic tool for checking problems.

It worked once, then crashed and now doesn't work. I would like to uninstall it, but it refuses to uninstall by the 'add/remove program' method. The install shield window appears and does it's thing for a bit then everything just stops.

There is no uninstall on the original CD either. I deleted the program file folder manually, but still appears in the add/remove program window.

Also I tried to re-install the program but it comes up with an error.

Any help would be appreciated

Thanks de-de

  cream. 14:03 17 Nov 07

use system restore to a date before you installed the softwaRE.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…