USB memory stick not showing up on pc

  mart7 08 Nov 13
Locked

My usb memory stick isnt showing up in "my computer"

In device manager it shows as a generic flash drive "this device is working properly"

In partition manager i get the message "the device is not ready",i use part man to format the memory stick to fat 32

Windows 7 operating system

Any help appreciated,ive had some problems with this previously but using partition manager to delete and reformat previously worked but not on this occasion

  mart7 10 Nov 13

bump this up see if anyone has any ideas

  Jollyjohn 10 Nov 13

It's probably the stick. I have four different makes and the TDK one does not work on my W XP laptop. It works on a Linux box, a W7 box and on my virtual systems.

  mart7 10 Nov 13

i am beginning to think that because i have had problems withis before,my other 2 sticks are fine

  rdave13 10 Nov 13

Does it show in disk management? Try assigning it a letter.

  mart7 10 Nov 13

yes it does its assigned itself to G:

have changed it to f but still doesnt show in My computer and same message in partition manager,device not ready,thinking its faulty now as i have had this problem before but partition manager reformatted it previously successfully

  rdave13 10 Nov 13

It might be that if the drive is empty then windows doesn't show it. I think the route is computer, organize, folder options and untick the box for hide empty drives.

Advertisement

This thread is now locked and can not be replied to.

Windows 10 Home vs Windows 10 Pro comparison: Here are the extra features you get in the Pro version

Behind the scenes at Silverstone, the 70th British Grand Prix: Hisense starts UK push with Red…

How Found created this skateboard, bike and parkour stunts-laden, single-take car ad

Apple Pay UK launch date, UK user guide and participating UK banks | Apple Pay to launch in UK on 1?…

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message