USB Mass Storage problem

  dms05 12:42 23 Dec 07
Locked

I've run a USB Card Reader for a long time without any problems. However today I connected a USB Stick (2GB with an unusual format) and immediately lost my additional Drives for SD Cards and so on. I tried going to Device Manager and uninstalling all USB's. On a restart these were correctly recognised except for the Card Reader (reported as Unknown Device and further investigation showed no Driver was necessary). I then tried a Restore Point but that didn't work either.

All my USB devices now work except for Card Readers (I've tried 2) and USB Memory Sticks.

Any idea how I can recover these items?

could be letter allocation problem
click here

  dms05 13:32 23 Dec 07

Thanks *Raven*, that's one of the most comprehensive USB troubleshooting webites I've seen.

Another point - I normally connect all my USB devices through a powered USB Hub. Everything works except USB Sticks and Memory Cards in a Card Reader. However if I plug the Card Reader directlt into one of my laptops USB ports then they do work. Really odd. I've tried 2 powered hubs and see the same effect.

  dms05 15:09 23 Dec 07

I've now tried the same configuration in Linux (I have a dual boot option of XP/PCLinuxOS) and exactly the same problem exists so it's looking more like a hardware problem. The problem occured when I introduced a USB Stick into a powered hub.

This thread is now locked and can not be replied to.

Hands-on: Acer Predator Triton 700 review

D&AD Awards 2017: see the best design, advertising, illustration, animation and VR of the past year

How to lose weight with an Apple Watch