USB hub not recognised

  dac2000_uk 12:54 07 Aug 03

I purchased a USB hub that converted 1 of my USB ports into 4 ports. I use it for my 4 printers, and they work fine through the device HOWEVER when I turn on the computer the screen is blank and the system doesnt boot up if the USB hub is in place (I have to take it out then turn the computer on again and I have to put the hub back in when the computer has booted) As you can imagine this is a bit of a nuisance and it is as if the computer doesn't recognise the hub or something despite the devices still working! help!

  xania 14:32 07 Aug 03

Please provide details of your MOBO and BIOS (Version and date). You might like to consider click here specialised site for your query - you normally get a response within 24 hours.

  dac2000_uk 14:36 07 Aug 03

Thanks for that xania...btw what is the mobo and bios?? lol

  Jester2K II 14:39 07 Aug 03

Mobo = Motherboard - make and model required

BIOS = The "brain" of the Motherboard as it where. xania is asking for the version number thats flashed up at the beginning of the boot up sequence.

  dac2000_uk 18:33 15 Aug 03

I aint got a clue bout any of that lol. I do know its a pentium one motherboard and I think it was built in about 1995. If thats any help

This thread is now locked and can not be replied to.

Microsoft Surface Studio PC release date, pricing, design, features and spec: Microsoft showcases…

1995-2015: How technology has changed the world in 20 years

This amazing app turns your iPad Pro into a Cintiq

Apple Q4 2016 financial results | Apple earnings report: iPhone, iPad and Mac sales down, profits d6…