USB freezes my pc

  moneylender 18:08 12 Nov 04

Recently installed XP pro with SP2.
I have 4 usb slots, one is used for my adsl modem.
The problem is if I install my camera as soon as I plug it in to any of the usb's, it totally freezes the PC and a restart is the only way top gain control.

Any help to point me in the right direction please.


  Diodorus Siculus 00:12 22 Nov 04


  moneylender 23:23 22 Nov 04

Very helpful


  Diodorus Siculus 08:16 23 Nov 04

In case you have misunderstood, bump is simply a means of bringing a posting to the top of the list before it disappears without trace.

Maybe someone will be able to help.

  moneylender 20:33 23 Nov 04

Diodorus Siculus

thanks for that and my appologies to the board!
Still have the problem, am learning to live with it now, unless someone can help.


  Gongoozler 20:38 23 Nov 04

Hi moneylender, can you tell us more about your computer? Some motherboards have problems with USB. In particular some older VIA chipsets weren't very good at supplying current to the USB devices. If that is the problem, you may find that a PCI USB card or powered USB hub will help.

  Diodorus Siculus 21:11 23 Nov 04

moneylender - no worries; I took it that you didn't know the meaning of bump!

As suggested, pass on more details and someone may be able to offer a solution.

  Fruit Bat /\0/\ 21:25 23 Nov 04

Perhaps your camera is power hungry the adsl modem certainly is, try it with out the modem plugged in does it still freeze the PC?

If so the only solution is a powered hub.

  moneylender 22:58 23 Nov 04


PC is a Packard Bell Iextreme 9000. Has 4 USB and a Firewire. OS is XP pro, usb's worked fine before clean install of XP!!
M Board is Micro-Star Inc. MS-6309 1.0
Hope this helps.


  johnandlin 12:45 08 Jan 05

I have a packard bell platinum with the same motherboard. My pc locks everytime I plug in a new usb connection such as my mp3 player.
I tend to hibernate, plug in and restart then they work fine. Bit of a pain though, I intend to install a USB2 PCI card soon

  Terry Brown 13:33 08 Jan 05

It sounds as if you need an updated power supply. I had a similar problem, when I added a USB printer and USB scanner to my system, upgraded power supply from 250 to 350 watt. Problem solved.

This thread is now locked and can not be replied to.

How to watch Surface PC live stream | Surface PC release date, price, spec rumours: All-in-one…

1995-2015: How technology has changed the world in 20 years

Best Photoshop video tutorials: 8 video tutorial websites for Photoshop

Apple's event invitations decoded: A look back at 16 of Apple's most cryptic invites | Clues in…