USB File Corruption

  srwpchelp 16:24 13 Jun 10
Locked

Hi,

Just recently, I've been having problems transferring data from my PC to my USB stick using Windows Explorer. Everything seems fine until you select a folder on the USB stick. The sub-folder names & filenames contain random letters/numbers/symbols. Strangly, some of the new created folders are fine.

I've re-formatted the USB many times (FAT32).
Still no joy. Seems to be OK when I transfer small files & folders.

I've used 2 USB sticks (8GB & 16GB)- same problem with each.

I've used different USB ports on my PC (front / back) - makes no difference.

I have Windows Vista (32 bit) and 2GB of RAM.

Any idea as to what the problem might be?
Transfer size problem?
Is there a file copy program that I can use instead of Windows Explorer?

Thanks,
Steve.

  rawprawn 16:35 13 Jun 10

Try a system file check click here for instructions.

  srwpchelp 17:39 13 Jun 10

Hi rawprawn,

I tried the system file check.
No problems found.

Cheers,
Steve.

  rawprawn 18:46 13 Jun 10

As a matter of interest, try copying to a cd.
Also look in Device manager at your USB Drivers.

  rawprawn 18:47 13 Jun 10

You could try uninstalling the USB Drivers and then rebooting to let Vista reload them.

  Im a diddy 19:10 13 Jun 10

teracopy click here

  srwpchelp 06:52 14 Jun 10

Hi,

I tried teracopy 3 times - all failed.

Small folders are OK.
Large amounts of data (GB) seem OK but are corrupt when trying to open. On the 3rd attempt, all files were corrupted (e.g. doc,xls,jpeg,mp3).
For info, the folders names were OK with teracopy.

How do you delete your USB drivers?
I went into Device Manager and USB Controllers. I'm not sure what (if anything) I should delete.

  john bunyan 06:56 14 Jun 10

I am not sure of this but FAT32 only handles folders to a certain size. Could this be a line to follow? Do not know if memory sticts etc are suitable for NTFS - others may comment.

  john bunyan 07:03 14 Jun 10
  john bunyan 07:05 14 Jun 10

Probably worth changing - format to NTFS

  rawprawn 08:14 14 Jun 10

john bunyan is right Fat32 will only take folders up to 4gb, I hadn't realised that yours were so big. This error usually occurs when people are trying to backup onto FAT32

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…