USB Devices not recognised in Windows 7?

  BenedictMonro 00:14 06 Nov 14
Locked

Hey guy's.

So I'm fairly new to the world of custom PC building, i've tried a few tech support forums in the past but this is my first post here. So hello! and I hope to be able to contribute more so in future.

However recently I upgraded my CPU from an i5 to an i7 and changed my Z87-G45 motherboard for a Z97-G45. The keyboard and mouse work fine in BIOS, yet when I boot into windows, all the lights on my devices go out and I cant use anything!

I've tried changing the USB ports, resetting the BIOS, but to no avail! Is there something I'm missing?

Seriously any help would be greatly appreciated!

Cheers.

  onthelimit1 08:39 06 Nov 14

Have you loaded the chip drivers from the CD that came with the mobo?

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This stop-frame animation tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…