USB Device Not Recognized

  phildux1 20:46 11 Jul 09
Locked

i hope somebody might be able to help as i am going Crazy. op system Win xp pro sp2. got myself today a secondhand Oki Laser Colour Printer C5600 work perfectly well when i brought it tried to set it up on my computer although there were no instillation disks thought no problem set it up through the wizard no problems. plugged it into the power , put in the USB Cable and it comes up with "USB Device Not Recognized" so did start> run> Devmgmt.msc up comes the device manager scrolled down to the usb section and there it is unknown device. tried to down load the drivers from the oki website but it will not load them it. is there anything else i can try
Best Regards
Phil

  Stuartli 21:43 11 Jul 09

USB devices normally require the drivers to be installed first and the device connected when directed.

Guides etc:

click here

You've probably found this drivers page:

click here

  Stuartli 21:46 11 Jul 09

Could also be worthwhile updating the motherboard drivers.

  woodchip 22:52 11 Jul 09

USB drivers should be loaded before you plug the printer in.

  woodchip 22:59 11 Jul 09

If it does not work after uninstall, uninstall again then use Add new Hardware wizard in Control Panel. Choose from List of hardware USB mouse you need to load the HID-compliant mouse

  woodchip 23:00 11 Jul 09

sorry the last post for wrong thread

  phildux1 10:46 12 Jul 09

Thanks for all your help. i have tried to download the setup drivers for the printer from the Oki Website filename OKIC5800w2kGB.exe (i think) but when i open up the downloaded file there is not setup icon

  Stuartli 10:54 12 Jul 09

Have you followed the instructions correctly?

click here

  phildux1 11:05 12 Jul 09

not to sure which one of those is the setup files so might not have download the right file

  Stuartli 13:44 12 Jul 09

You have, it would appear, the correct file for XP - you need to download the file and then Unzip it to a specific destination.

You could create a New Folder in Program Files (My Computer) and Unzip it there - then you will find your Setup link.

  phildux1 13:57 12 Jul 09

done that but there is deffinatly no setup icon. but on the oki website it says under drivers

"OKIC5800w2kGB.exe 1.0.8 1883kB 02/05/2007 Y Y Y Fixed colour printing issue when ProQ2400 resolution option is selected."

click here

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Framestore’s haunting post-WWII title sequence for new BBC series SS-GB

How to install MacOS Sierra on an older Mac: Get Sierra running on Macs & MacBooks from before 2009