USB Device Not Recognised

  mpearo 20:20 29 Aug 07
Locked

Hi,

Having a problem with USB hard drive / USB memory sticks when connecting them to my PC (Windows XP)

Message appears in the bubble saying that it's found and installing the unknown device. Then says installed and ready for use, then shows the following error.

USB Device not recognised

One of the USB devices attached to this computer has malfunctioned and windows does not recognise it. For assistance resolving click this message.

Clicking the message brings up a box with a 6 port usb hub with one of them taken up with unknown device.

I have tried uninstalling all USB devices via device manager but this has not resolved it.

Recognises other usb devices (floppy drive, camera etc) ok but just not storage drives.

They also work fine on my laptop so I know it is not the external drives themselves.

Can anyone help ?

Thanks

  woodchip 20:24 29 Aug 07

Go to device Manager Uninstall bottom half of USB list to refresh the list then restart computer

  woodchip 20:31 29 Aug 07

You have to right click My computer to get the above in the link

  mpearo 20:29 31 Aug 07

Tried following the instructions from the link but no luck. Neither the flash drive or external hard drive are showing, only the C drive.

  mpearo 20:30 31 Aug 07

also tried uninstalling the bottom half of the usb list, no luck so tried uninstalling all of them but i'm still getting the same error message.

download tweak ui
click here
once downloaded,launch program

click my computer,this expands to show drives,autoplay etc
click drives, reveals a to z of drive letters try unticking a couple with the drive volume icon against it,then reboot,on start up see if the drive has now been allocated a drive letter or appears in disk management

  mpearo 18:17 03 Sep 07

still no luck, downloaded and followed the instructions but still does not recognise them.

are the usb ports/devices 2.o high speed?
check in device manager for enhanced usb controller

do you get exclamation marks in device manager?
device manager>view>show hidden devices

the only other thing i can think of is to uninstall/refresh usb stack in safe mode
click here
follow the link,refresh the usb stack in the exact order.

  woodchip 18:56 03 Sep 07

Have you loaded SP2 on this computer?

  mpearo 21:38 03 Sep 07

All,

Having checked a few places someone suggested turning off and unplugging the machine for 30 mins.

I did that amazingly it worked !!! - Has something to do with a buildup of charge on the motherboard apparently (similar to what happens with sky boxes sometimes).

Thanks for all the help

Mark

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced