USB Connector problems

  BlueBooze77 13:44 24 Sep 08
Locked

Hi

I am a novice in this area, so hopefully someone can help me out with this!

I bought a PC about 3 years ago - and over the last year, whenever I try and connect something through a USB port (like a camera, printer or memory stick) my PC does not recognise it! I get the New Hardware Found pop up bubble - but then when I try and go through the steps of the installation wizard, it never completes and works.

Is there anything simple that I can do to fix this issue?

Thanks

  Pamy 14:30 24 Sep 08

Hi BlueBooze77, what operating system are you running? XP usually finds it like you describe then says new hardware ready for use, you do not have a wizard

  BlueBooze77 14:48 24 Sep 08

Hi Pamy - I am on XP. When I connect something, I get the New Hardware Found bubble - then it goes to an installation wizard - that is when I have the problems - I cannot get any further :(

Do you think I need to update my XP?

  Pamy 14:59 24 Sep 08

My XP is fully updated but I would be supprised if that was the problem. I do not get a wizard it just comes up with "hardware installed and ready for use".

  Fried~Chips 15:01 24 Sep 08

when a usb 2 device is connected to a USB 1 hub, also Chipset drivers and also known faulty PSU to cause this.

  €dstowe 15:02 24 Sep 08

With some things (printers and cameras come to mind) it is important - essential even - to install the software before you connect the USB device. Is this the way you are doing things?

This thread is now locked and can not be replied to.

Surface Pro 5 News - release date, UK price, features, specs

Microsoft Surface Studio hands-on review: the iMac killer is here

Best Mac antivirus 2017