USB Adaptor problem - help please

  Smile:-) 15:11 16 Jul 07
Locked

Hello,

I have bought a Belkin G+ USB wireless adaptor and have installed that on my laptop.

It has found my home network and tells me it is connected but it won't open the internet.

Have tried the belking tech help number but this is in india and now more confused than ever, as the advise I got was to reload everything and then it was still the same!

Can anyone give me a clue as to what I need to do.

All help will be gratefully read

Thanks

  recap 15:36 16 Jul 07

Disable the Windows Firewall and leave the Router Firewall enabled.

  postie24 18:23 16 Jul 07

Also disable the encryption and see if it connects.
If yes,go back into the router homepage and check the settings for security.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…