USB 2.0 root hub

  woody147 18:26 28 Apr 03
Locked

I've recently had to re-install windows XP from my backup repair disk and have installed service pack 1 so that USB 2.0 devices are recognised. However, in device manager i now have 3 USB Root Hubs listed whereas before i had 2 USB Root Hubs and a USB 2.0 Root hub. any reason why? I have an Asus A7N8X deluxe mobo - before you ask i've tried ALL the latest drivers from Nvidia and microsoft :-)

  ThisNameIsMine 18:29 28 Apr 03

Does the root hub work? If it works then it doesn't matter what widndows detects it as!

  woody147 18:36 28 Apr 03

it appears to although i guess if it's detecting it as a standard rather than a 2.0 hub it will run about 40 times slower!

  jimv7 19:40 28 Apr 03

Delete all of them from device manager and restart the computer, it should then find and install all thats relevant.

  mrdsgs 20:29 28 Apr 03

there may be a usb 2.0 driver on your motherboard driver disk/cd. it's worth looking.

  woody147 20:34 28 Apr 03

tried all drivers, from microsoft to nvidia website to nvidia driver disk, no luck. deleted from device manager and restarted aswell, same prob :-(

  misery 20:47 28 Apr 03

you've installed the latest mobo driver(s) from the mobo manufacturer?

  woody147 22:15 28 Apr 03

yep, as my original message said "before you ask, i've tried all the latest drivers from Nvidia and microsoft" :-)

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation technologies coming to Siggraph 2017

iPad Pro 12.9 vs Surface Pro 5