USB 2 support

  Graphicool1 12:12 PM 06 Jun 11

I recently did a clean install of WinXP. I now have all the updates known to man. However, what I don't have is USB 2.

Any suggestions gratefully received.

  mgmcc 12:17 PM 06 Jun 11

Presumably you don't have the "Enhanced Host Controller" listed in Device Manager so USB is functioning as 1.1 instead of 2.0? Try deleting all of the listed USB Host Controllers then reboot so that Windows "finds new hardware" and reinstalls them, hopefully including the USB 2.0 support.

  Graphicool1 12:33 PM 06 Jun 11


No, unfortunately I tried that but it didn't work. These are what I have...

ALi PCI to USB Open Host Controller

ALi PCI to USB Open Host Controller

ALi PCI to USB Open Host Controller

SiS 7001 PCI to USB Open Host Controller

SiS 7001 PCI to USB Open Host Controller

USB Mass Storage Device

USB Root Hub

USB Root Hub

USB Root Hub

USB Root Hub

USB Root Hub

  birdface 12:57 PM 06 Jun 11

Looks like you need SP1 at least to have it.

link text

maybe run the fix it and see if that helps.

  Fruit Bat /\0/\ 14:44 PM 06 Jun 11

Yes you need to install the service packs sp2 and sp3 - SP2 contains SP1.

Also looks as if you have onboard USB and a USB card fitted ALi and SIS if you still do not have the enhanced controller after the SP updates then you will need to download the drivers from ALi and SIS

USB man will have or point you to all the drivers you need.

  Graphicool1 15:24 PM 06 Jun 11


Trouble is you can nolonger get SP1, or at least I haven't been able to. I've got a USBEHCI.sys on another PC.

Oh, wait a minute, I've just looked into this PC's 'i386' file. Here, there are three blue cabinets (cab). The are labelled 'sp1' ~ 'sp2' ~ 'sp3'. inside each are, among other things there are USB drivers. However, none contain 'usbehci.sys'. What if I were to copy it from my other PC and drop one in each cab?

  birdface 18:27 PM 06 Jun 11

Had a look on my computer W/7 and it is on here.


Just scroll down to usbehci.sys and see if it is on there.

I had a terrible time last week trying to install a usb driver as it said not digitally signed so would not let me download it.

I eventually managed it but don't ask me how.

  Fruit Bat /\0/\ 18:49 PM 06 Jun 11


This is how you allow unsigned drivers in windows 7


SP2 contains SP1. so all you need is to install SP2 then SP3

  woodchip 20:15 PM 06 Jun 11

As above you only needs SP2 and 3 this will get your USB2 working without anything else

  birdface 21:19 PM 06 Jun 11

Thanks Fruit Bat /\0/\

I have bookmarked it in case I need it again.

  Graphicool1 18:30 PM 07 Jun 11

Update and an Amazing Discovery!

Fruit Bat /\0/\

"SP2 contains SP1. so all you need is to install SP2 then SP3"

Sadly, been there, done that, to no avail. In fact since I was last here I've been all over the Internet, reading everything I could find, regarding USB2. But every time I just came out clutching fresh air. I've downloaded many, many possiblities, but still nothing. Then I realised that all of a sudden, all my USB devices had stopped working. Things were going from bad to worse. So I tried a 'System Restore'. But nomatter how far back I went, it wouldn't restore. I was begining to lose the will to live.

This was when I thought I would try the idea I mentioned above, taking a usbehci.sys file from my other PC and manually installing it. I'd already transferred it from my other PC, before all this went down. It wouldn't let me do it. But while I was trying I noticed something very odd? There, for all the world to see, was a usbehci.sys file. I could see it so why couldn't the PC. So once again I decided to act outside of the box. I deleted it from the driver file and also cleared it from the bin. Then I rebooted...

I now have USB2 and everything is working again!!?? Don't ask, I have no idea.


This thread is now locked and can not be replied to.

How to watch Rugby World Cup 2015 online: Watch live, catch up on-demand & stream the 2015 Rugby…

1995-2015: How technology has changed the world in 20 years

See immersive artist and storyteller Chris Milk speak at London VR event

What everyone thinks of the new Steve Jobs movie | 21 Facts about the Steve Jobs film | PLUS:…