usb 2

  jbaker65 10:02 20 Oct 08

The manual for my Asrock K7S41 motherboard specifies that the usb ports are usb 2. However the device manager does not say that the usb ports are "enhanced". Since the usb 2 drivers are supposed to be from SP1 upwards and my Windows has SP3, can anyone suggest why I still don't have fast USB?

  Technotiger 10:06 20 Oct 08

Have you checked that USB is enabled in the BIOS, and/or have you tried clicking on Update drivers in USB, Devices?

  jbaker65 10:56 20 Oct 08

Hi Technotiger, Ive tried updating driver and there is nowhere in the bios which mentions enabling usb????

  Stuartli 11:11 20 Oct 08

The Bios may provide the means to Enable up to, say, six or eight USB2 ports.

Check you have the latest motherboard drivers for your mobo from the Asrock website.

Also see:

click here

  Stuartli 11:15 20 Oct 08

It's more likely that Device Manager will list Enhanced USB Host Controller(s).

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

New Corel ParticleShop plugin now available: 11 new brushes & 6 new brush packs

Apple AirPods review: Apple's beautiful new Bluetooth headphones bring true intelligence to…