Unreadable sata drive

  skidzy 17:34 05 Apr 07
Locked

Ive just bought a New 80GB sata drive and planned on using this as an external drive temporarily.I have the connection kit and usb caddy but sadly the drive is not recognised in My Computer but is recognised in Disk Management.
Disk Management reports Unreadable.This is on a Vista machine fully updated and clean.

Could this be possible that the drive has been formatted in Fat32 and not NTFS,therefore unreadable by Vista ?

Ive yet to try this drive on my other computers (different location),though it is needed for this computer.

Im guessing its a faulty drive......

As usual all advice welcome and greatly appreciated.
Thankyou all.

  skidzy 19:05 05 Apr 07

^ Bump ^

  Technotiger 19:13 05 Apr 07

Hi, looks as if you will have to wait until you can try it on another machine, sorry I can't offer any solution, other than that. Best to hope in fact that it is a faulty drive, at least that way you could then get a replacement.

  skidzy 19:16 05 Apr 07

Hi Techno,im wondering if this needs formatting on a xp machine for Vista to recognise this.No problem with the external ide drives..just the sata drive.

Cheers for the input anyway my friend.

  laurie53 20:37 05 Apr 07

I hestitate to offer advice to such as yourself, skidzy, but I had this as an ongoing problem.

I could solve it for a little while with a reboot, and/or a disconnect/reconnect, but it never really went away.

Since I had used the drive elsewhere I put it down to a faulty caddy.

Laurie

  skidzy 20:41 05 Apr 07

All advice welcome here my friend,have tried 2 caddies and a sata/ide convertor cable and still no joy.
ide drives are fine,its just this sata thats leads me to think its faulty.

I have also restarted a couple of times with the drive connected,but again...no joy.

Thankyou for your input.

  skidzy 13:22 06 Apr 07

^ Bump ^

  Fruit Bat /\0/\ 13:27 06 Apr 07

New 80GB sata drive

HAve you tried to right click the drive select initialise and then format?

  skidzy 13:31 06 Apr 07

Yes FB,all i get is properties,nothing else.Give me a mo and will try again.Back in 2 mins.
Cheers FB

  skidzy 13:36 06 Apr 07

ok FB,all i get is properties and help.Properties just takes me the usb device...policy/General/Volume etc...
Here it shows unreadable and 0MB

I am going to try it on an xp machine later to see if any difference.

Thankyou FB

  skidzy 15:35 06 Apr 07

Tested in 4 more xp machines and still no joy.

I have ordered a new caddy with a twoway usb connector,as i think it may be lacking power.

Will update as soon as i received and tried the new caddy.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now