unknown device during startup ?

  grabster 22:00 30 Sep 04
Locked

After i boot my pc,XP home, a window pops up stating that HDC has the "wrong driver for this device".
Under device manager where my secondary ide channel should be there is unknown device,i cant enable the device or rollback driver, and uninstalling device doesnt help either.
My system works fine , it is a pain haveing to close the error window every time i boot up or switch log-ins.
I dont recall tinkering with anything that may have caused this .
Any ideas anyone ?

  Dan the Confused 22:07 30 Sep 04

What motherboard do you have? Have you tried reinstalling the MB drivers?

  Night Ryder 22:10 30 Sep 04

Have you tried updating and letting windows search for a suitable driver. If this is doesn't work the driver may be on you motherboard setup disk.

  Diodorus Siculus 22:12 30 Sep 04

Try a registry cleaner in case it is a legacy of a previous uninstall.

  grabster 22:18 30 Sep 04

I have tried letting windows search but it finds nothing and i run regcleaner now and again but it makes no difference,i have a gigabyte MB ,i'll have a look for the cd and i will let you know how i get on .

  grabster 21:00 01 Oct 04

Well,tried MB driver disc,still no joy...
now i have another error popup as well..."there was a problem sending the command to the programme" with an ok box. ???
dearie me.

  Dan the Confused 21:10 01 Oct 04

What program?

What does Device Manager say now? Is there a secondary IDE device now?

  grabster 07:29 02 Oct 04

Mmm.. still says unknown device.
I get the new error when i d/c on any IE shortcut,when i close the error box the requested page opens as normal.

  Mango Grummit 07:50 02 Oct 04

Try this: unplug all USB devices and then do a registry clean in *SAFE* mode.

Then reboot without USB devices connected and see what you get.

  grabster 13:38 02 Oct 04

Thanks for your suggestion Mango Grummit but alas i still have my problem(s).
I was gonna reinstall xp but as i have sp2 installed things aint that simple...
during the installation i am informed that my xp is different and i may lose my settings. does that mean i lose everything ? i dont mind reinstalling sp2 again but i dont wanna lose all my stuff.

  grabster 13:22 03 Oct 04

ditto...

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…