Unknown Device

  BigAl127 13:11 16 Dec 06
Locked

Got a Packard Bell Easynote R1935 Laptop. Device manager is showing an unknown device, which instance ID shows as ACPI\MTC0007\4&365B0&0.

I know ACPI is Advanced Configuration & Power Interface. But am unable to find the relevant driver.

Packard Bell's XP home as been removed and XP Pro installed in it's place. Was able to download all other drivers from PB's website, just got a problem with this one driver.

Any advice appreciated.

  keith-236785 15:58 16 Dec 06

first of all, try updating the drivers via device manager and let it search the internet for new drivers.

if that doesnt work, try removing it from device manager and then clicking check for hardware changes in the file menu, when it finds the unknown device it should ask for access to check the internet...allow it to check for you.

  BigAl127 17:22 16 Dec 06

Thanx for the reply, unfortunately i've already tried your ideas without success.

I've tried googling the instance id, but I only get foreign replies.

  keith-236785 14:52 18 Dec 06

click here
not sure if the A5 is the same as your pc.

or

click here (you will need your serial num,ber of your pc to get any further than this but as i dont have a PB pc then i dont know if it will help.

  keith-236785 14:54 18 Dec 06

sorry pressed post too quick.

try downloading ALL the files from the first link, then try using the downloaded files to setup the unknown device.

good luck

  BigAl127 15:48 18 Dec 06

Have followed your second link, For the R1935 without success.

Not sure whether any of the A5 ones will work, and a bit reluctant to try them.

The lack of the driver, doesn't appear to be causing any problem with the laptop, so might just leave the driver uninstalled/ not updated.

Once again, Many thanks

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…