uninstall XP

  krsna 10:26 01 Jun 04
Locked

I have installed both XP pro & home on my pc, and I tried to take off XP home by deleting the one set windows folder, but when I start the pc a screen appears which gives me the option of which operating system to use, how can I stop this screen from appearing.

  johnsims 10:32 01 Jun 04

You should have uninstalled XP home rather than just deleting the Windows folder. The registry still thinks you have two operating systems and is asking you which one you want to boot into.

Try using Add Remove Programs from Control Panel to uninstall XP Home. This may work despite the fact there is no windows folder for it.

For the future, NEVER delete an application folder without first running an UNINSTALL - preferably from Control Panel - Add Remove Programs

  krsna 11:55 01 Jun 04

Thanks for the advice johnsimms, but i don't think that xp home or pro is listed on the ads/remove program page, is there some way to force it appear on the add/remove list?

  Newuser1970 14:56 02 Jun 04

You need to alter the "boot.ini" file which is in the C:\ drive. Make sure you back it up before making any changes. Below is a copy of my boot.ini file on which I have a dual boot of Win 98 and Win XP pro.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(1)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
C:\="Microsoft Windows 98"

When I removed Win XP I had to alter the above
to

[boot loader]
timeout=30
default=C:[operating systems]
C:\="Microsoft Windows 98"

It then removed the choice and booted straight to Win 98

Good luck.

  krsna 15:22 03 Jun 04

Newuser1970, I tried to follow your instructions, but I cannot find the boot.ini file, you say it is in the c:\drive, I am unable to see this on explorer could you kindly spell it out for me. Thanks.

  Newuser1970 23:11 03 Jun 04

I have rechecked my C: drive and it is probable that you are unable to see the boot.ini file because it is a hidden file.

To make it visible open 'my computer' and then open C drive. At the top menu hit 'view'. At the bottom hit 'Folder Options'. Open the 'view'tag and move down 'Files and folders' to 'Hidden files'. Put a dot in the 'Show all files' circle. Hit 'apply' and OK.

The boot.ini file should now be visible.

Good luck

  temp003 05:06 04 Jun 04

Boot into XP pro. Open My Computer. Tools, Folder Options, View tab. Tick Show hidden files and folders. Untick "Hide file extensions for known file types". Untick "Hide protected operating system files". Click OK.

Double click your C drive. You should see boot.ini (and also ntldr and ntdetect.com).

Before you make any changes, back up the existing boot files first. Insert a floppy. Right click A drive, select Format, and just click Start (don't tick any boxes). After formatting, copy the 3 files ntldr, ntdetect.com and boot.ini to the A drive. Remove floppy.

Right click My Computer, Properties, Advanced, Startup and Recovery, Settings. In the section default operating system, make sure XP Pro is selected. If not, click the down arrow and select it. Click OK, OK until you exit My Computer Properties.

Then go back into Startup and Recovery, Settings, as above, and click the Edit button. This opens the c:\boot.ini file in Notepad.

In the section under [operating systems], delete the line which refers to XP Home.

The line should read something like multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home" /fastdetect

Just delete that line.

Click File, Save.

Exit Notepad.

Click OK until you exit My Computer Properties.

Restart. It should go straight into XP Pro.

If everything goes well, you can copy the new c:\boot.ini file to the floppy you created earlier, replacing the existing boot.ini on the floppy. This floppy will serve as a back up of your boot files and can boot you into XP Pro as well.

You can go back into Folder Options, and reset the View settings if you like (but better keep Hide file extensions unticked).

  krsna 12:37 07 Jun 04

Thanks to Newuser1970 & temp003 I have managed to stop the unwanted screen page coming up.
Thanks lads

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…