Unable tio VIEW my 02 online bill pls HELP!!!

  julius44 20:14 15 Aug 08
Locked

Hello there, ive been an 02 customer for about 2 years now, and i registered for online billing about 2 years ago. I am able to log into the 02 webite fine without any problems with my username and password, and down the left handside of the webpage theres a link that says 'View my bill'. Obviously i click, but then i'm given 4 links such as my profile, my mobile, online help, get 02 active. I have called 02 on several occastions and they;ve told me clear my temp files..which i've done, also to make sure my IE browser is 128-bit encryption, which it already was anyway,.

My point is with BOTH FF3 and IE7, the link to view my bill does not work..as i cannot see the bill, and i need to get some fone numbers from previous bills, and check other things, etc. Does anyone else have this problem??? All other links seem to work fine..on my 02 account ..but the view my bill link just wont display my bill, it just shows my profile, my mobile etc. Any suggestions please???

  octal 20:21 15 Aug 08

I'm on O2 and I've logged in OK. What I did notice is that when you click on My bill it takes you to the secure sires that starts with https:// check to make sure your firewall is not blocking https or port 440.

  julius44 20:26 15 Aug 08

Hi octal i have kaspersky internet security 2009, and the firewall seems to be preset, i dont know how to check if port 440 is free or not. do u think the firewall is the problem?? but i can clicl on all other links, and i also have t-mobile online and i can view my t-mob bill ok?

  octal 20:28 15 Aug 08

Sorry, that should be port 443. what happens when you try and click on this link? click here

  julius44 20:45 15 Aug 08

Hi octal when i clicked on the link it DID take me to a diffrent webpage.

Also Beta, u said u had exactly the same problem??!! r u still with 02? and do u still have this problem please??

  octal 20:59 15 Aug 08

That link I gave you takes you to a secure web page via an https. If you can get into that page then the problem could be with your ISP. Just one other thing, have you tried switching off your router then switching it back on again? Sometimes that gets things working.

  julius44 21:36 15 Aug 08

hi otcal, the link worked fine, and when i probed port 433, it said the port was in stealth mode. My isp is Virgin media by ehe way. any other suggestions??

  woodchip 21:52 15 Aug 08

its your Firewall try turning it off to get into 02

  octal 22:06 15 Aug 08

I haven't got any other ideas at the moment, suffice to say that I'm on Virgin Media as well and I don't have any problem getting into the O2 site. Just one question, when you hover the cursor over the link, does the cursor change into a little hand? I'm just asking that to make sure the View My Bill is a clickable link.

This thread is now locked and can not be replied to.

Sony Xperia XZ Premium review: Hands-on with the new 4K HDR phone with Motion Eye camera and Snapdr5…

1995-2015: How technology has changed the world in 20 years

Best laptop for design and art 2017: we test Apple, Dell, HP, Lenovo and Microsoft's best models…

CarPlay tips & troubleshooting guide: CarPlay tips & troubleshooting guide: Get the most from…