Unable to mount External HDD

  skippettman 22:59 23 Jan 07
Locked

This one has got me stumped!

I bought a Toshiba 320gb Usb 2.0 external hard drive, plug and play device and connected as per instructions but nothing happened, the system did not recognise it. tried add new hardware, could not find.

So I purchased a new usb 2.0 pci card thinking it might be a usb 1.1 - 2.0 issue (that was before I knew how to chesk for usb capability on my system, i have checked and have standard 'enhanced' usb).

When I went to install the new pci card the system does not load this hardware either. I get 3 usb controllers showing up in the device manager all with yellow ?. tried uninstalling and re-installing but nothing happens.

So tried to mount the hard drive on my old laptop, mounted and installed no problem. i have run virus checks and all ok.

the system I am running is:
window home xp (sp2, all updated to latest patches)
amd 64 processor 3500+

any clues to how to solve this would be very appreciated.....
please...... :-(

  Diodorus Siculus 06:54 24 Jan 07

What is the rating of your PSU? Could be overloaded...

  skippettman 08:43 24 Jan 07

"What is the rating of your PSU? Could be overloaded..."

How can I find that out??

This thread is now locked and can not be replied to.

AMD Ryzen release date, specifications and features: Three CPUs from the Ryzen 7 range now…

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

Best iPhone games 2017 | Best iPad games 2017: 162 fantastic iOS games that you need to play right…