Unable to install any programs

  s99Raj 20:51 19 Feb 09
Locked

I have a desktop which, for no apparent reason, went "funny" one day when the Internet was blocked on it. I tried loading a program, but it wouldn't let me.

The internet connection is fine as it works with another pc. I decided to format the problem one and reinstall XP Home. It went smoothly and I have installed NOTHING else - just the basic XP Home with SP2. It only needs the sound drivers putting on next.

However, I still cannot install ANYTHING on it. I've tried installing Office 2007, AVG, Roxio Basic, and others. It starts, but then simply does a rollback and tells me that the installation was interrupted.

I've also tried installing WindowsInstaller-KB893803-v2-x86.exe but that gets interrupted too, saying that the service was halted.

What's going on? Thank you.

  Technotiger 20:54 19 Feb 09

Check the Power options in Control Panel, make sure nothing is turning itself off.

  s99Raj 20:55 19 Feb 09

Power Options are as normal - nothing is switching off.

  Technotiger 21:10 19 Feb 09

What do you mean when you say "one day when the Internet was blocked"?

XP installation went smoothly, so I guess it is not a virus, though I would have suggested running a scan to rule that out, also Malware type scan.

Can you put AVG download onto a Flash drive and get it onto the computer that way - then run a scan?

  s99Raj 21:14 19 Feb 09

"one day when the Internet was blocked"
Basically, the Internet suddenly stopped working; no connection was possible so I thought I'd do a re-format etc.

I've tried running AVG off a flash drive - same problem.

  Technotiger 21:20 19 Feb 09

Hmm, the Internet just doesn't 'stop working' - your pc lost its connection, so you should have asked for help on that score rather than doing a re-install of windows.

Try following the instructions here click here although it is a different program involved, the principle is the same.

  Rahere 21:24 19 Feb 09

A few questions

Did you wipe the drive and reinstall from scratch or repair?

Is your user account set as administrator? - sometimes if you set up your account as a normal user (not admin) you won't be able to install programs at all.

Try in safe mode or set up a new account as an admin and see if this works OK

  s99Raj 21:27 19 Feb 09

I wiped and reinstalled from scratch.
The accouint is Administrator.

  Rahere 21:51 19 Feb 09

Have you tried in safe mode?

Posibly it could be a DEP (data execution prevention issue)Chek this in control panel go to system under the Advanced tab click on Performance then the third tab is data execution prevention make sure that it is only selected for windows programs and services and not all programs.

Otherwise it could be a case of wipe and install again. This time do not connect to the internet before you apply XP SP3 - Download the full XP SP3 patch on the other computer and apply this before you do anything else. Once you have installed it you should be OK to receive updates

  s99Raj 22:12 19 Feb 09

This is crazy - I've done nothing different but thought I'd have another go, and now all is well. All programs are loading correctly.

Can't think why they didn't the first time round, esp. since I've made no changes. Wonder if it'll just suddenly stop working again properly. I'll set a few restore points just in case.

Thanks for everyone's suggestions.

  Technotiger 22:15 19 Feb 09

Grreat, well lets hope it remains stable from now on.

Cheers.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Method Studios' title sequence for BBC series Taboo is truly unsettling

Best Pages for iOS tips | How to use Pages for iPad & iPhone: 6 simple tips to get more out of…