Unable to boot into XP

  avesnes1 16:51 15 Jul 14
Locked
Answered

I have W7 on one internal drive and XP on a second and backups kept on a removable and an external drive. Recently I tried to get into XP and a message flashed by saying something like " Windows/system32/config/system/........(too quick to read)...... is missing"

The result was a black screen. I now get the black screen (without the message) having selected XP from the choice of W7, XP, etc. which appears after the BIOS screens.

I have backups using Acronis and I was wondering if any member could tell me which files and/or folders might be missing. I could then recover the individual file/s from a backup using Acronis. I'm trying to avoid using the entire backup which would return my data files to where they were a couple of weeks ago.

Thanks in advance for any comment/guidance.

  Fruit Bat /\0/\ 17:26 15 Jul 14

Missing Or Corrupt Windows\System32\Conf\System File

First try just copying the file "system" from the above location in your back up and use it to overwrite (or delete the system file first) in the same location on your XP drive.

see if it will then reboot.

If not then there is a few more files that will need replacing.

  Batch 16:10 16 Jul 14
Answer

Are you connecting the W7 and XP disks one at a time (i.e. not both at the saem time) OR do both spin up all the time and you use a boot manager to determine which OS to load?

If it is the former, it may well be that it is looking for HAL.DLL (HAL = Hardware Abstraction Layer), which is one of the first files accessed. The location of the \Windows path (that HAL.DLL resides in under \System32) is determined by boot.ini which is a text file located in the root of the boot drive (e.g. C:/). If boot.ini is corrupt or incorrectly set-up HAL.DLL cannot be located. If this might be the case, google for Repair boot.ini.

If it is the latter, the above might still be the issue (I say that as I'm not entirely sure how it works in a multi-OS system with a boot loader). If not....

  avesnes1 21:29 16 Jul 14

My first reply seems to have disappeared?

Many thanks for the replies.

I tried Fruitbat's suggestion of copying files and folders all the way back to system32 into Windows but to no avail.

Before seeing Batch's suggestions, I had decided to copy any files dated after my last backup. I could do this from W7 as I could still see the files on the hard drive that contained XP. I put those files on my external drive.

Using Acronis,I then did a complete restore from my removable drive onto the internal drive that held the corrupted(?) XP.

This took about an hour and 40/45 minutes but was successful. I then booted into the revived XP and copied the post-backup files back from my external drive into XP.

Thanks again for the suggestions but at least my sledge hammer approach has worked.

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This stop-frame animation tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…