Ultra DMA Mode 5

  turnip 60 01:25 19 Feb 05
Locked

I recently transferred my pc to a new case and since then on boot up I see 'Ultra DMA Mode 5 Not Enabled'. can you please tell me what affect this has on my pc and also how to enable it.could this be the cause of boot up taking as long as 3 minutes.
I run Windows XP Pro. with SP2
Regards

  FelixTCat 07:26 19 Feb 05

There are two modes of transfer from a hard disk, PIO and DMA. DMA (Direct Memory Addressing) is much faster. Windows will usually choose DMA if available, but you may have to go into Device Manager - Hard Disk - Properties and tick the DMA box.

Ultra DMA also requires an 80 strand IDE cable to connect the disk to the motherboard. If you use an older 40 strand cable, the disk cannot run at its fastest and you may well get a message like the one you have.

  dan11 12:10 19 Feb 05

As you are using windows XP.

Go to control panel > system > hardware > device manager > IDE ATA/ATAPI controllers > primary IDE channel > advanced settings > transfer mode.

Use the drop down box. Is DMA available there and what mode. Pick 5 if availble.;-)

You may need a 80wire - 40 pin IDE cable as FelixTCat has suggested.

  turnip 60 12:30 19 Feb 05

Many thanks Felix & Dan but i have tried that several times choosing the 'DMA if available'in device manager but it still shows up on bootup as available but disabled. yes i am on XP pro with SP2
any more suggestions please.
Regards

  dan11 12:55 19 Feb 05

Are you getting any DMA ( 1 or 2 or 3)mode for the harddrive. If you are, then it's more than likely the IDE ribbon cable.

If you are only getting PIO mode, then this might be worth investigating;

They are settings in SOME bios's that can turn on or off the DMA mode. The motherboard make and model would be required.

  turnip 60 13:51 19 Feb 05

Hi Dan11
On boot up it shows in the diagnostics as:Ultra DMA 5 s.m.a.r.t. capable but disabled.
In device manager it states:Current Transfer Mode'Ultra DMA Mode 5.
I have just rechecked all the cables and they seem to be seated tight.
My motherboard is Asrock K7VM2. Bios P1.90
regards

  FelixTCat 14:00 19 Feb 05

If Device Manager states that the current transfer mode is Ultra DMA Mode 5, then I'm not clear what the problem is. Windows would appear to be activating DMA.

If you want to see why Windows is taking so long to boot up, there is an option in the boot menu (press F8 on startup) to see the loading sequence. Watch Windows boot and note which part of the boot is taking so long.

You can also tell Windows to keep a log file of the boot process which will help.

  JonnyTub 14:15 19 Feb 05

I think your confusing the bios's statement when it say's: Ultra DMA 5 s.m.a.r.t. capable but disabled. There's two seperate things here, the bios is reporting that the current transfer mode is as stated (ultra dma 5) and smart disabled (Self-Monitoring, Analysis and Reporting Technology ) is best left disabled as it will cause a disk to slow down.

Everything's fine....as is

  turnip 60 14:17 19 Feb 05

FelixTCat, I was not sure wether to take notice of the Diagnostics showing DMA 5 disabled or device manager showing DMA 5 as my current transfer mode.
As far as the Boot up taking a long time, after the windows XP screen disapears the screen is black for approx 3 minutes before the welcome screen appears.

  turnip 60 14:23 19 Feb 05

I Do Apologise Gentlemen, I omitted to mention the S.M.A.R.T. part in my previous notes.Thank you JonnyTubb for spotting that.I appreciate all your comments.
Many thanks.

  JonnyTub 14:24 19 Feb 05

Your long boot time is probably attributed to programmes starting at bootup, remove non-essentials from the startup list.

This thread is now locked and can not be replied to.

New Google phones UK release date | Pixel XL price, new features, specifications: Pixel X and…

1995-2015: How technology has changed the world in 20 years

This is the future of TV, VR and holograms

iPhone 7 review: Enhanced cameras, a refreshed design and water resistance make the iPhone 7 an…