Ultra DMA mode

  rioboy 10:44 14 May 04
Locked

Got a problem with my DVD-RW drive which I'm trying to troubleshoot. It won't read any medium that I put into it. This occured when I used it as a recorder for the first time last night.
Its an Optorite DD0201 and I have upgraded the firmware and uninstalled and reinstalled the device.

I have noticed in Device Manager that the secondary IDE channel (0) is showing a current transfer mode of PIO mode even though I have DMA mode if available selected. Could this be a reason for it not working.

  SEASHANTY 16:19 14 May 04

My secondary IDE controller also shows PIO mode. You can try setting this to DMA but I think you will find that it reverts back again to PIO. Updating firmware on Optical drives causes many problems and unless its done exactly as stated you end up with a U/S drive. Maybe somebody else will come in with a possible cause.

  woodchip 16:25 14 May 04

Are you on XP if so it may only work with proper software i.e. NERO or such

  Djohn 16:26 14 May 04

Have you set this from Device manager/IDE/ATA/ATAPI controller/secondary IDE chanel/properties/advanced settings?

  rioboy 17:34 14 May 04

|Thanks for the responses. I've managed to get Ultra DMA back by uninstalling the secondary IDE channel from Device Manager and then rebooting, however the DVDRW drive will still not read anything I put into it. If I insert medium into the drive I do get an icon on that drive letter in My Computer but when I double click I get the message "E drive inaccessible. Incorrect function". (E is correct).

May try putting the device in another machine to see if I get the same result. Working nights tonight so will not be able to respond to any messages till the morning.

  Djohn 18:10 14 May 04

Do you have just the one optical drive or two? if so have you checked the jumper on the rear and set it to master or slave as necessary?

If you set to master make sure it's connected to the end of the IDE cable, if slave the middle connector. You can also set the jumper to [CS] Cable select and your PC will recognise it by itself. j.

  Captain Black 20:02 14 May 04

I have had very similar problem with new Sony combo fitted to a new machine. The error message was the same as yours, the fix was to update my Roxio and windows drivers, once done no more problems. check you have the latest software patches installed, it solved my problem.

  SEASHANTY 14:09 16 May 04

See note 42 on this website Hints and Tips for Windows XP
click here

  rioboy 16:06 16 May 04

Thanks for all the help. I put the offending drive into 2 other working machines and although it was recognised and installed it would still not read any medium. I guess its died so it will be packaged up and returned to the supplier.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…