UDMA Problem

  blackfazer 09:32 11 Jul 03
Locked

My system

Asus A7S333 MoBo, Primary IDE has 20gb HD and Liteon 52x CD-R, secondary IDE has 120gb HD and Pioneer A05 DVD burner. AMD 2400+ CPU, 512mb PC2100 RAM. Windows XP Pro.

My Problem

The secondary IDE is very slow and I can only configure it to use PIO. It's set on Auto in the bios so I don't really have much control over it.

Any ideas how I can speed things up, please ?

The MoBo manual states that both IDE connections are UDMA 100 and that I need to use 80-pin cables. This I am doing.

  DieSse 09:36 11 Jul 03

Try it with the DVD disconnected - Optical and magnetic drives do not always co-exist happily on the same IDE channel, and it can vary from make to make.

Have you loaded the motherboard chipset drivers - if not then you should - they may change matters.

  blackfazer 14:48 11 Jul 03

Thanx for the imput.

I've put both HDs on the primary channel and the CD and DVD burner on the secondary channel.

The slave HD is now very fast but both the burners are now burning slower than they should be.

Sisoft Sandra reports only one ATA/Atapi controller. Is this normal ?

Therre doesn't seem to be any support for UDMA on the secondary IDE channel. I'm baffled. :-(

  DieSse 18:22 11 Jul 03

Have a look in the BIOS and see if the secondary IDE channel is configured correctly.

  DieSse 18:27 11 Jul 03

Also try the CD-writer (the one that was on the primary, originally) on it's own, in case of a problem on the DVD drive.

AND - try another IDE cable (or swap them around if all else fails

OR - I have seen some optical drives that didn't like 80 wire cables - try it with a 40 wire instead.

  blackfazer 19:16 11 Jul 03

Thanx again.

I've tried all your suggestions and nothing has worked. I've decided that the easiest thing for me to do is install a PCI IDE card and see if that solves the problem.

I've not had a problem like this before. I've only had this computer running for about six weeks, I built it myself, but it's only since I've upgraded to faster hardware that I've noticed the problem. Everything was fine on my old system.

Oh well...:-/

Thanx again for you time and input, it's appreciated.

  woodchip 19:21 11 Jul 03

Go to Device Manager and set the DVD to DMA, you may have probs if you do it with CDRW but you can try it

  ellas 22:22 11 Jul 03

I have the same problem on a nforce board with xp,my secondary ide is also PIO,reading about this its set by xp(my bios is also on auto)as you may get errors in dma,I have tried everything to enable dma,you dont say what chipset,I also have a computer with a intel chipset which has no problems with dma on all IDE's but the nvidia chipset even though higher spec wont enable it for the secondary channel.

  madPentium 23:23 11 Jul 03

I recently upgraded my bios (7 versions out of date LOL) and many were to address hard drive speed problems in XP. The system seems a lot more stable and faster now. Mine is an intel too.

  blackfazer 08:54 12 Jul 03

The chipset is SIS 745.

Thanx to everyone for thier thoughts.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…