Ubuntu Camera dection problem.

  Simsy 18:37 14 Jun 11


I'm dual booting, (2 different hard drives), Win 7 and Ubuntu on a fairly new computer. (Self built, just before Christmas).

The Ubuntu installation, (10.10), has stopped detecting my camera, (Canon Powershot A540), and also the Logitech webcam.

The webcam was previously detected in a "strange" way; It's a USB with combined microphone... Ubuntu couldn't see the camera, but using Skype in Ubuntu the camera worked just fine, as did the mic.

The situation now is that the mic still works, including in Skype, but the webcam doesn't, and Ubuntu can't detect the Canon camera at all.

It's obviously to do with the Ubuntu installation as all is well with the Windows installation, (thus eliminating a hardware issue), and if I boot into a live CD of Ubuntu, (the one I installed from), it detects the Camera OK.

I'm guessing that the problem is related to cameras in a generic sense, but I haven't got a clue where to start.

Any suggestions anyone?

Thanks in advance,



  ams4127 20:17 14 Jun 11

I would suggest upgrading to version 11.04. I find it more stable than 10.10 and have had no compatability problems using it.

If you still want to stay with your current version then you might be better off asking your question on the Ubuntu forums. They probably have more Linux experts than on these forums.

  Simsy 20:30 14 Jun 11

Thanks ams4127...

I didn't like 11.04.

This is the only problem I've had with 10.10. I've been using it since it was released, spent some time getting it set up with the stuff I want, so I'd like to keep with it if I can.

It's perhaps not obvious from my post, but the Still Canon camera was working OK with this before... it's not that it's never worked.

I've looked on linux forums, (and am still doing), with no joy so far.

If I need to re-install/upgrade I will eventually do so, but I'd like to avoid taht if possible!




  woodchip 20:42 14 Jun 11

I would say that its got mixed up with you Web Cam, and Canon Camera as the Canon can be used as a Web Cam.

PS what does it do if you remove one of them?

  woodchip 20:43 14 Jun 11

Try Having one in at a time change them over

  LastChip 21:44 14 Jun 11

At a guess, I suspect Ubuntu is not seeing your USB device(s).

I think when you plug your camera in, it's being seen as a USB device and automatically being configured as such.

Open a terminal and type this command:

sudo lsusb

and hit enter.

You'll be asked for your password; type it in and hit enter again.

Note the output on the screen.

Now plug your camera in, give it 30 seconds or so and repeat the command and see if your camera has appeared in the list.

Let us know the result.

  Simsy 22:25 14 Jun 11


Camera is in the list... as is webcam... but it's not visible in any useable sense... I can't access it from Nautilus or any graphics programme.

Forgive me... but bed beckons! I'll revisit this tomorrow!

Many thanks for interest and help.

Woodchip... no that's not it. Webcam not working when it's the only thing connected. Canon camera not useable under any conditions.




  LastChip 22:45 14 Jun 11

OK, that's sort of half good news, the possibility is then, it's not being auto-mounted.

So, close your computer down, plug the camera into the computer and turn the camera on.

Now boot your computer in the normal way and let us know the result please.

  Simsy 08:36 15 Jun 11


I've tried that. In fact that's what I normally do... No difference. I have tried plugging camera in, then turning it on, and the otherway round. I've tried switching camera between "viewing" and "taking" modes, (and all permutations of when to plug in, switch on, etc), with no success.

I'm at work now, so won't be able to try anything else before this evening.

Thanks for your interest and help.



  Simsy 08:40 15 Jun 11

Whoops... I've just re-read your last post woodchip... I may not have tried booting up with the camera connected and turned on. I'll try that tonight.



  Simsy 08:29 16 Jun 11

Hi again...

Last night I tried booting up with the camera connected and turned on. No improvement. (in fact my keyboard/mouse usb combo failed to work when I did that... possibly a fluke/red herring?)...

However, having plugged in another usb mouse, (without rebooting), I did discover that the camera could be seen in picasa, and in F-Spot photo manager, though not in "Shotwell".

I rebooted again, without the camera connected, and when I connected the camera it could, again, be seen in picasa and F-spot, (and presumably always could... I'd not tried before).

So I'm a little furtehr on, but it's not as it should be, or as it was.

I realise this is a difficult one to diagnose remotely, but I'd still appreciate any more suggestions.

Many Thanks,



This thread is now locked and can not be replied to.

Samsung Galaxy S8 review

1995-2015: How technology has changed the world in 20 years

What’s happening in VR right now: From psychedelic art to combat therapy

Siri not working? Try these troubleshooting fixes