Ubuntu 10.10 doesn't recognise my hard drive

  GarySimpson 11:18 29 Oct 10

My computer became infected with Backdoor.tidserv!inf, which infected one of the drivers in my Windows folder. Attempts to remove the virus manually were unsuccessful; the Norton removal tool froze half way through, and the computer froze every time I tried to replace/copy/delete the infected file. After running the Norton tool, the computer would no longer boot into Windows, even in safe mode - the blue screen of death appeared and I ended up in a rebooting loop. Resigned to re-installing Vista, I want to try and retrieve some files on my C: drive before doing so. I have managed to restart the computer by using Ubuntu 10.10 on a bootable CD, but Ubuntu does not recognise my C: drive, so I am not able to access the data to back it up. Any suggestions?

  jamesd1981 11:24 29 Oct 10

you could try downloading hiren`s boot cd, on it theres is mini bootable versions of linux and windows xp, you could try booting into xp via hiren`s disc and access your drive from there.

  GarySimpson 11:36 29 Oct 10

Thanks - will certainly give this a try. Hiren's Boot CD looks as if it has a number of programs on it, most of which I have no prior experience of. Given the problem, would you advise any particular programs which would be useful in accessing the C: drive and retreiving data without transferring the virus within the Windows folder?

  scotty 12:43 29 Oct 10

Could be that the disc needs to be mounted. When you open the file manager (From menu, select Places then Computer) do you see the disc listed? Note that it will be called something other than C drive, possibly sda1 or similar. When you identify the disc, right click and select Mount.

  GarySimpson 12:57 29 Oct 10

No, the disc isn't listed. The only way I can "see" the hard dtive is through System > Administration > Disk utility where it appears under the SATA Host Adapter

  LastChip 13:07 29 Oct 10

and type:

fdisk -l

Exactly as I've written above and tell me the result.

  LastChip 13:08 29 Oct 10


fdisk space hypen lower case L

  jamesd1981 14:30 29 Oct 10

you dont need the other programs for your cuurrent problem, when u have the disc ready, put in your disk drive, reboot the machine, and boot from the cd, when it starts your top option is boot from hard drive and below that you will see mini windows xp double click that and it will boot into xp using the disk, and you should be able to access all drives and partions connected.

  GarySimpson 15:40 29 Oct 10

LastChip - thanks for the help

Nothing happened at all. Just went back to the command prompt

  Jollyjohn 16:12 29 Oct 10

Have been following this - I suspect a hardware issue with the hdd or the motherboard.
On next boot enter the bios and see if the hdd is detected - if not then remove the hdd and try it another PC. Check the jumpers on the back of this hdd and set it to slave.
If you can see the hdd - good - run Malewarebytes to scan the drive then navigate to Documents and settings folder and copy the My Documents folder to dvd or removable drive.
If you dont have a spare PC to try the drive in your local PC repair shop will and they should not charge much to check the integrity of the hdd.

  LastChip 00:09 30 Oct 10

It's the fact that Ubuntu uses sudo; try this:

sudo fdisk -l

It may ask for a password. If it does, just hit enter again. As you've not provided a password for the live CD, one doesn't exist, but the application needs to follow its procedure.

Like Jollyjohn, I'm suspecting a hard drive fault as well, which is why I needed the output from that command.

This thread is now locked and can not be replied to.

Sony Xperia XZ Premium review: Hands-on with the new 4K HDR phone with Motion Eye camera and Snapdr5…

1995-2015: How technology has changed the world in 20 years

Best laptop for design and art 2017: we test Apple, Dell, HP, Lenovo and Microsoft's best models…

CarPlay tips & troubleshooting guide: CarPlay tips & troubleshooting guide: Get the most from…