Tyring to connect to wireless router

  cheechman 13:03 30 May 07

I've had a good long look through the board but can't find exaxtly what I'm looking for......

I've re-formatted my laptop and want to reconnect to my wireless router (Belkin 54g). I have two other machines running off the router one wireless and one via ethernet. All run independently.

I had no problems with the laptop previously however when I am trying to connect I am entering the passcode all what happens is that it says "Acquiring Network Address" and stays like that.

Any pointers?

  ArrGee 13:26 30 May 07

Try to remove and re-install the drivers for the router on the laptop, then connect via an ethernet cable first. Once a connection is established, download any required updates, then connect without the cable.

  FreeCell 16:07 30 May 07

I doubt you have any specific drivers on your pc for the router as it is a networked device.There are only standard network drivers.

Seems to be trying to assign an IP address to your PC and failing. Have you tried right clicking on the system tray icon and selecting "Repair". Forces network to assign an address to PC.

  Fruit Bat /\0/\ 17:22 30 May 07

Satrt - run - type services.msc press ok

scroll down the services and check that DHCP and DNS client have both started.

If not right click select properties, in the startup type box select automatic (so it starts next time you boot) click on the start button.

then retry to connect to the router.

  cheechman 20:39 30 May 07


I've right clicked on icon and it just freezes at "Renewing your IP address". The it stops saying this action could not be completed.


Both "DHCP and DNS" have both started.

I did try switching the router off and back on again. I then had problems reconnecting the desktop (which is connected to router via Ethernet cable). I did a System Restore on the desktop and that fixed it! (Hence being able to ask for help). I can't do that with the laptop because restored the thing back to the beginning.

I'm really puzzled as the first time I connected it to woreless was unbelievably easy!

  woodchip 20:50 30 May 07

You have to load all the Motherboard Drivers for the Laptop from the CD or may be on another partition

  cheechman 20:56 30 May 07


Thanks but what does that mean?

I've inserted the Restore CD which told me it would delete everything it then did all its bits. That is the only CD I got with the machine.

  FreeCell 20:57 30 May 07

Couple of things to try/check.

Right-click wireless network icon in System Tray.
Select Status - then Properties.
Scroll down in box to select "Internet Protocol (TCP/IP)". Select Properies and make sure "Obtain IP Address Automatically" is selected.
Click Advanced and check in WINS tab that NetBios is set to "Default"

  woodchip 21:01 30 May 07

Restore should load all the drivers and it should be back just as you bought the Laptop. So you need to go through what you did before to get it to connect. if it's WiFi you may need to turn it on with a combination of key's on the keyboard

  cheechman 21:23 30 May 07

Freecall all checked and correct

woodchip I've done exactly the same as when I first bought the laptop

It finding the connection and saying it is connected but in the Status it says Limited or no connectivity. (Because the network did not assign a network address to the computer)

I've tried using the Network Setup address Wizard using a flash drive. All steps are completed and confirmed that the laptop is now connected to the "XYZ" network.

Strange!! It looks like a phone call to an expensive helpline tomorrow!

  cheechman 21:24 30 May 07

Oops the only thing I couldn't do with the flash drive is plug it into the router as it doesn't have a USB port.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now