Trouble installing Canon Digital Camera software

  griffo 21:02 25 Mar 07

I'm having trouble with installing Canon Utilities PhotoSwitch 3.1 and Zoombrowser software.

I've installed and used it with no problems on one XP PC but when I tried to install it onto another XP PC the installation just froze. I stopped it through Task Manager (eventually!). I went to Add/Remove Software and deleted what was showing for it (PhotoSwitch 3.1), then used Registry Mechanic to remove any Registry entries. Used Search to make sure there weren't any other files lingering, then re-booted.

Each time I re-try to install it, it says Canon Utilities PhotoSwitch 3.1 has already been installed in your PC. There is no need to reinstall!! It then halts setup.

Can anyone please advise how I might overcome this please?

  Stuartli 21:07 25 Mar 07

I use a memory card reader/writer for downloading my Minolta digital camera files (Secure Digital card) and Picasa2 for photo editing the files.

  jack 21:12 25 Mar 07

The general wisdom appears to be 'Dont use the supplied software just leave it in the box and let Windows do the work',
You may have indulge in a bit of Regedit work to remove the last vestiges of the soft ware.
Simple to do if you feel up to it.

  chocolate cake 21:18 25 Mar 07

Have you tried a system restore to before you tried the install?

  skidzy 21:18 25 Mar 07

I have a canon ixus50 and the software is a pain to remove totally.
It has to be removed in the correct order.I never did get around to removing all the features of the software,and never needed them either...big mistake loading this in the first place.

have you tried removing via safemode.

  griffo 21:26 25 Mar 07

The software works fine on our other PC, so I don't wish to condemn it - yet!

How would I do a regedit and would a system restore to a point before the first attempt to install the software be a better option?

Skidsy - I haven't tried safe mode, but I can't find anything left of it to uninstall! Clearly, there something somewhere?

  woodchip 21:28 25 Mar 07

To do a Clean of Canon, Use Restore to before you tried loading it

  woodchip 21:35 25 Mar 07

If you know another name than Canon that the Software uses you will have to use that. But this is the way to clean Regedit.

Start\Run type regedit press enter go to Edit in Menu\Find type what you are looking for Canon. The tree on the left should only show base folders press enter Do not delet anything other than what you are looking for. It.s also a good idea to backup the registry when you are new to editing. After it find's the first item, press del then enter key then F3 for next in regedit till you get to the end

  skidzy 21:41 25 Mar 07

Obviously you still have a registry entry somewhere.

Have a look in the registry

Start/run and type REGEDIT then navigate to HKEY_CURRENT_USER/SOFTWARE look for any thing to do with Canon and remove.
Though do backup the registry first,here is a guide to backup the registry click here

  skidzy 21:42 25 Mar 07

Sorry woodchip,forgot to refresh...

  griffo 22:04 25 Mar 07

Did a restore to a prior point, then tried a new install. It appeared to install PhotoSwitch 3.1 but then froze again. Anyway, I closed that and whereas it booted me out last time, it continued to install the rest of the software.

Having finished and rebooted, I've connected the camera and the software seems to be working OK, time will tell.

Thanks to all who responded, much appreciated.


This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the 2017 Oscar-winning VFX of The Jungle Book were created

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…