trouble with 4 Port USB Hub

  rawprawn 11:36 27 Mar 04
Locked

I bought a Belkin 4 port USB powered hub, when I connected it yesterday there were no problems, including the printer & scanner connections. This morning when I booted the computer I lost the connections to both the sacnner & printer, although I can get my camera to work, nor does it seem to like being connected to my ADSL Modem. Any advice would be helpful.

  sam2004 11:41 27 Mar 04

Belkin have a good helpline on (UK) 01933 352 000. I'm sure they, as the manufacturer, would be able to help.

I have no personal experience with USB hubs so cannot suggest anything, i hope you have more luck.

  Stuartli 11:44 27 Mar 04

If you go to Device Manager you can check that there are no question marks beside the device or the controllers.

  Salinger 11:46 27 Mar 04

You might find that ADSL Modems are recommended to be plugged directly into the computer, not via a hub.

  rawprawn 11:51 27 Mar 04

sam2004, Thanks for the phone number I may yet need it.
Stuarti, There are no problems shown in device manager & I have just tried the printer & scanner again & they are both OK. This morning there was a problem indicated in the device manager. I don't understand what has changed.

  rawprawn 11:55 27 Mar 04

I take on board what you say, & have the modem plugged into the comp. The strange thing is that even though it was directly into the computer I lost the connection this morning until I played about with it.I have 4 usb ports on my computer & they all seem OK.

  Paranoid Android 12:03 27 Mar 04

Are you using it powered, or self ? There should be a little switch on the side. For the devices you are using, you need to use the hub with mains power.

Marvin

  fitcher 12:31 27 Mar 04

buy a pci card save the messing

  rawprawn 12:35 27 Mar 04

I am using it powered, I have rebooted about 3 times now with no problem, I can't say it is cured, but everything seems OK. I will leave the thread open for a while in case of a sudden relapse. Thanks for all your responses.

  Stuartli 14:30 27 Mar 04

Printers and scanners, in particular the latter, should be used with a dedicated USB port and not through a hub.

This is most likely the cause of your problems.

  rawprawn 17:29 27 Mar 04

Thanks for the advice, I will take note & follow your advice.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…