Toshiba Satelite 1900 - Won't boot

  loudman 12:22 24 Jul 05
Locked

I have a major problem. My Toshiba Satelite 1900, WINXP Home edtn,(not SP2 updated) P4,2.0Ghz, 256mb RAM, won't boot up.

I was running Norton Sys works - speeddisk to defrag the HD. The screen was blank because the powersetting I have switchs it off after 10mins of no input.

My son passed the laptop with the (lid)open as he called it, and thought I forgot to close it as the screen was blank, and of course the laptop shut down. When I reopened the (lid) screen again it would not display and the system had no POST beeps . I tried to boot from a recovery floppy - no joy - I then tried to boot from a WINXP boot CD - again no joy. A friend gave a lend of his SPINRITE v6.0 disc to boot from as he says it has its own O/S - again not joy. The battery and power adapters are all ok we tested them with a multi-meter.

One further note is that I have GOBACK v3 installed but due to the fact the laptop wont boot I cannot recover the last good point. I also believe that as I was running a defrag program when this accident occured the restore points will be cleared.


At this point I am stumped. I have some work on the laptop (Excel Files) that I need to access. Any suggestions/help would be appreciated.

My last resort after this forum is to go to PCWorld clinic which I have never resorted in the past. The laptop was bought in PCWorld and I never had a problem with it.

  loudman 15:17 24 Jul 05

Anybody got ideas of what I might try???.

  loudman 17:55 24 Jul 05

I suppose all the experts are resting their brains today!!!!

  Fruit Bat /\0/\ 18:28 24 Jul 05

TRy

remove CMOS battery for 1 min to reset BIOS replace and then try to boot normally.

  loudman 16:48 25 Jul 05

I dont suppose you can tell me how to access the cmos battery on the satellite 1900-303. I reckon its behind the keyboard on the MB but how to access it is another problem.

Thank you for your reply it is probable the correct solution as I tried everythig else.

  anchor 09:36 26 Jul 05
  loudman 15:36 26 Jul 05

Thanks anchor for your advise also fruitbat for yours, it is much appreciated

  woodchip 15:42 26 Jul 05

Look's like it may be the internal POWER Supply

  woodchip 15:43 26 Jul 05

i.e. the Main battery print on motherboard may have a bad connection, as it seam's by your post that the Laptop is Dead

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…