Toshiba Laptop Screen Problem

  Chris Webster 23:28 PM 24 Nov 12
Locked

Hi all,

A friend has asked me to take a look at his mums laptop as the screen keeps going 'funny'.

The laptop works fine for a few minutes then the screen starts getting lines and blocks all over it.

The only thing I can liken it to is in the Matrix film when all the data starts streaming down the screen.

Also the laptop decides to restart itself every now and again too.

I managed to do a virus and malware scan and both came up clean

I've taken 2 photos of the screen and put them on my Flickr account to show how the screen looks, link below.

http://www.flickr.com/photos/76369868@N02/sets/72157632092798006/

Any ideas gratefully received,

Regards,

Chris.

  Chris Webster 23:33 PM 24 Nov 12

Sorry, forgot to put laptop details,

Toshiba Satellite L500-1DT

W7 Home Premium.

Regards,

Chris.

  onthelimit1 09:36 AM 25 Nov 12

Have you a normal PC monitor you can plug it into? That would help determine if the problem is with the chip or with the video cable, connection or screen.

  john bunyan 10:42 AM 25 Nov 12

At worst a new screen fitted is about £100

  Chris Webster 19:39 PM 25 Nov 12

Marg7,

I started in safe mode and left it running for quite a while, the laptop never restarted itself and the screen was fine.

Regards,

Chris.

  onthelimit1 22:33 PM 25 Nov 12

Hmmm - if the screen stayed stable in safe mode, that would appear to suggest the fault is with the graphics chip.

  Fruit Bat /\0/\ 20:41 PM 26 Nov 12

Agree if its stable in safe mode then its a driver problem - reinstall or update the graphics driver.

  Chris Webster 20:53 PM 27 Nov 12

Hi all,

I downloaded (from the Toshiba site) and installed the display / graphics drivers.

The laptop ran fine for around 30 to 40 minutes but then the same problem reappeared.

After having done a 'force' shut down and then restarted straight away it runs fine again for approx another 30 minutes before the same thing happens yet again.

Regards,

Chris.

  onthelimit1 08:51 AM 28 Nov 12

Sounds as though the graphics chip is misbehaving when it gets hot. You could try checking for dust build up around the fan, but it can be concealed.

  Chris Webster 20:57 PM 28 Nov 12

Hi,

I've checked for dust build up around the vents and fan and all seems clean.

I've also checked that the fan is working and it is.

Again it ran for about 30 to 40 minutes before the screen went 'strange' but the laptop did restart itself 3 times in the first few minutes after booting up.

Regards,

Chris.

  Fruit Bat /\0/\ 21:03 PM 28 Nov 12

Do you get any error messages on the restarts?

Advertisement

This thread is now locked and can not be replied to.

How to watch Sony Xperia Z5 launch live: Sony Xperia Z5 live video stream from IFA 2015 - watch…

1995-2015: How technology has changed the world in 20 years

DxO One 'pro' camera attachment for the iPhone: UK pricing & availability

What to expect at the September Apple event: Apple announces 9 September event, sends out invites