tiscali vista modems

  loganly 19:59 21 Mar 07
Locked

any one got there tiscali speedtouch modems to work on vista yet still no drivers and tiscali customer services are a joke !!

  Stuartli 20:03 21 Mar 07
  Stuartli 20:03 21 Mar 07

There is also "an up to 8MB" patch.

  skidzy 20:18 21 Mar 07

The problem lies with the modem drivers.

If no joy from Stuartli link,i found the only way to install the 330 modem was to make this the first usb device installed.I also had many problems,but got it to work eventually.
Hopefully the link above will sort this for you.



Stuartli:

Thankyou for the link,ive been checking for the new driver but not for a couple of days.Though im a little sceptical of trying it out as everything is ok with my 330.
You know what they say...if it aint broken !!

Cheers for the link,nice to know its there,just incase.

  loganly 20:29 21 Mar 07

tried all these drivers and no luck it just hangs up half way through install

  skidzy 20:38 21 Mar 07

If you have any printers etc connected by usb,uninstall them for now. Now try installing the modem driver from the desktop if you do not have the software disc.

This thread is now locked and can not be replied to.

Sony Xperia XZ Premium review: Hands-on with the new 4K HDR phone with Motion Eye camera and Snapdr5…

1995-2015: How technology has changed the world in 20 years

Best laptop for design and art 2017: we test Apple, Dell, HP, Lenovo and Microsoft's best models…

CarPlay tips & troubleshooting guide: CarPlay tips & troubleshooting guide: Get the most from…