TalkTalk's EchoLife HG520s router

  Spark6 20:24 19 Jul 07
Locked

I changed over to TalkTalk's Talk3 International service last week, set up the router on my desktop OK but am unable to use the wireless connection to my laptop.

I have used the supplied CD to set up the laptop, the LT is 'seeing' the router, but does not connect to the internet.

The telephone assistance re setting the wireless facility involves another subscription and no information is supplied with the router for trouble shooting.

Googling HG520s brings up a multitude of Chinese pages which, when translated, do not provide anything resembling an instruction manual.

Has anyone experienced and solved this problem?

  mikesuther 11:31 20 Jul 07

Hi, You say you can see the router from the LT, so have you configured the laptop?

Initially most manufacturers say to initially use a crossover cable to set up configuration of router once this is done remove cross over cable and you should be OK.

when you move the mouse so that the pointer is on the wireless icon in your system tray down by your clock does it give informatioon such as connection speed and quality? On my computer the wireless icon looks like a TV with two brackets to the right, the box of the TV should also be flashing.

I know this may sound stupid but have you made sure your wireless connection is switched on? It varies from machine to machine, on my Toshiba there is a switch on the front of the LT while on my Wifes LT she has a function button to press which has a wireless aerial symbol. Your LT definitley is wireless capable as some models need adapters fitted.

  Spark6 21:19 21 Jul 07

Sorry for the delay in responding but I've had other things on my mind. I've been able to download the updates for the laptop by using a cable to the router but no joy as yet wirelessly.

I'm rather disappointed that no instruction manual for the EchoLife HG520s router is available for downloading.

  Spark6 20:44 23 Jul 07

Having failed to connect wirelessly to the TalkTalk router I decided to try my Netgear DG834G router on the TalkTalk service earlier today. As I had previously downloaded and printed the Netgear setup manual the installation was relatively straightforward and I now have my laptop, plus a second desktop, connected wirelessly.

Why TalkTalk have not ensured that a setup manual is available beats me. I shall attempt to return their router ASAP.

  LeeThC 16:54 04 Aug 07

I have also just subscribed to TalkTalk with free internet access. Along with other users I also didn't receive any manual with my wireless Echolife modem but I have learnt a few things over the weeks, here they are:

Setting up a SECURE CONNECTION between an Echolife modem and a PC.
It is assumed you have already followed the instructions given by TalkTalk, supplied with your modem to set up an unsecure connection, and it is working.


Modem part: (MODEM SHOULD BE CONNECTED TO POWER AND TELEPHONE LINE)
1. Connect PC to modem via red Ethernet cable.(If you don't have an ethernet connection on your PC you may be able to do it wirelessly)
2. Open Internet Explorer.
3. Type in 192.168.1.1 in top bar.
4. A new window should open.
5. Type in 'admin' as username and 'admin' as password.
6. Click on BASIC.
7. Click on Wireless Lan.
8. Choose your Authentication type - WPA or WPA2 are best.
9. Choose your Encryption as TKIP.(YOU CAN ALSO CHOOSE AES BUT I USED TKIP)
10. Enter a Password (min 8 characters).
11.Click Submit at bottom of page.
12.Click on Tools.
13.Select Logout and close window.

Setting up PC side of security: (MODEM MUST BE SWITCHED ON AND CONNECTED TO TELEPHONE LINE)
1. Click on Start icon in bottom left corner.
2. Click 'Connect to'.
3. PC should display available networks.
4. Find your network and right click on it.
5. Select Properties then Security.
6. You should now be able to enter what Authentication your modem is using (WEP,WPA etc) along with Encryption (TKIP or AES) and your password.
7. OK all that, select your network and you should be able to connect not just wirelessly but securely!

Changing the modem password
1. Open Internet explorer.
2. Type 192.168.1.1 in top bar.
3. A new window should open.
4. Type in 'admin' as username and 'admin' as password.
5. Click on Tools.
6. Click on System Management.
7. Double click pencil icon.
8. Enter 'admin' as old password.
9. Enter your new password.
10. Enter your new password again as stated.
11. Click on Submit at botton of page.
12. Click on Tools.
13. Select Logout and close window!

  Spark6 20:34 04 Aug 07

I had no problems setting up the router with the ethernet cable to my main computer, also my laptop connected OK with the cable. No problems setting up WPA security either. The problem I encountered was setting it up wirelessly to the laptop and a second desktop!

The information supplied for wireless setup was about as much use as a chocolate teapot, unless, of course, you are willing to pay extra for the geek squad. I, most certainly, am not.

  andy8771 16:38 11 Aug 07

I followed this thread and now have a secured network,However when I tried to alter the password from Admin Admin I now can no longer gain access to the routers settings !! : ( I have tried the other password that was posted but to no avail.I also spoke to Talk Talk who told me to call the geek squad.But I am so not going to pay £25 for a password! Can anyone assist please ??
Thanks

  Spark6 20:07 11 Aug 07

Are you using the router supplied by TalkTalk? I am still unable to access the settings on mine so I'm relying on my Netgear unit.

No reply to my letter dated 12/07/07 to Charles Dunstone as yet and I'm having grave doubts re my decision to purchase the TalkTalk router. My only consolation is that it wasn't too expensive at £25.

Anyone else reading this, and considering changing over to TalkTalk, please think carefully about your choice of router unless you are prepared to pay extra for the Geek Squad's services!

  LeeThC 12:42 13 Aug 07

If you can no longer access your Echolife router with your password you may need to reset the router and start again from scratch. To reset the modem you need to push the reset button on the back of the modem using a pin. Obviously all your settings will be lost as it will revert back to it's factory settings. Good luck!

  Spark6 14:29 13 Aug 07

Many thanks for your interest in this thread. Have you been able to set up wireless communication between your computers using the EchoLife router?

  LeeThC 16:00 13 Aug 07

Hello Spark6, Yes I successfully set up a secure wireless connection between my Echolife wireless router and my Acer laptop running Vista. I only have one laptop in the property. I have however now switched to a Buffalo wireless router due to my Echolife somedays loosing the connection every 3 or 4 minutes! I found that the Echolife worked really well if I was in the same room as it but when I moved upstairs with my laptop the signal became intermittant. If you want a reliable, reasonably priced modem, you can get a Buffalo at Ebuyer or on Ebay, that's where I brought mine!

This thread is now locked and can not be replied to.

What is ransomware and how do I protect my PC from WannaCry?

Disney layout supervisor Rob Dressel on the challenges of visualising Moana

Siri vs Google Assistant